Bug 251047 - [libata] Hard lock caused by error recovery failing
[libata] Hard lock caused by error recovery failing
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-06 14:37 EDT by Andy Lawrence
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-25 05:53:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output showing ext3 errors and hardware profile (49.63 KB, text/plain)
2007-08-06 14:37 EDT, Andy Lawrence
no flags Details

  None (edit)
Description Andy Lawrence 2007-08-06 14:37:24 EDT
Description of problem:
Complete system freeze after a few minutes of activity.  Seems to happen 
quicker with network traffic.  

A problem on the following kernels:
kernel-2.6.22.1-27.fc7
kernel-2.6.22.1-33.fc7
kernel-2.6.22.1-41.fc7

Kernel kernel-2.6.21-1.3242.fc8 is not effected.


How reproducible:
Every time, just give it a minuted or two to lock up.  Loading Amarok usually 
does the trick!

Steps to Reproduce:
1.  Start computer
2.  Load Amarok, surf the net, copy files over the network
3.  System will lock everytime

Additional info:
Comment 1 Andy Lawrence 2007-08-06 14:37:24 EDT
Created attachment 160761 [details]
dmesg output showing ext3 errors and hardware profile
Comment 2 Chuck Ebbert 2007-08-06 15:09:30 EDT
Everything starts out OK:

libata version 2.21 loaded.
pata_via 0000:00:0f.1: version 0.3.1
scsi0 : pata_via
scsi1 : pata_via
ata1: PATA max UDMA/133 cmd 0x000101f0 ctl 0x000103f6 bmdma 0x0001fc00 irq 14
ata2: PATA max UDMA/133 cmd 0x00010170 ctl 0x00010376 bmdma 0x0001fc08 irq 15
ata1.00: ATA-7: WDC WD2500JB-00REA0, 20.00K20, max UDMA/100
ata1.00: 488397168 sectors, multi 16: LBA48 
ata1.00: configured for UDMA/100
ata2.00: ATA-5: MAXTOR 4K060H3, A08.1500, max UDMA/100
ata2.00: 117266688 sectors, multi 16: LBA 
ata2.01: ATAPI: LITE-ON DVDRW SOHW-1633S, BS0H, max UDMA/66
ata2.00: configured for UDMA/100
ata2.01: configured for UDMA/66

Later:

ata2.01: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata2.01: cmd a0/00:00:00:00:20/00:00:00:00:00/b0 tag 0 cdb 0x43 data 12 in
         res 40/00:03:00:00:20/00:00:00:00:00/b0 Emask 0x4 (timeout)
ata2: soft resetting port
ata2.00: qc timeout (cmd 0xf8)
ata2.00: ata_hpa_resize 1: hpa sectors (0) is smaller than sectors (117266688)
ata2.00: limited to UDMA/33 due to 40-wire cable
ata2.01: limited to UDMA/33 due to 40-wire cable
ata2.00: failed to set xfermode (err_mask=0x40)
ata2: failed to recover some devices, retrying in 5 secs
ata2: soft resetting port
ata2.00: qc timeout (cmd 0xf8)
ata2.00: ata_hpa_resize 1: hpa sectors (0) is smaller than sectors (117266688)
ata2.00: failed to set xfermode (err_mask=0x40)
ata2.00: limiting speed to UDMA/33:PIO3
ata2: failed to recover some devices, retrying in 5 secs
ata2: soft resetting port
ata2.00: qc timeout (cmd 0xf8)
ata2.00: ata_hpa_resize 1: hpa sectors (0) is smaller than sectors (117266688)
ata2.00: failed to set xfermode (err_mask=0x40)
ata2.00: disabled
ata2: failed to recover some devices, retrying in 5 secs
ata2.01: failed to set xfermode (err_mask=0x40)
ata2: failed to recover some devices, retrying in 5 secs
ata2: soft resetting port
ata2.01: configured for UDMA/33
ata2: EH complete
ata2.01: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata2.01: cmd a0/00:00:00:00:20/00:00:00:00:00/b0 tag 0 cdb 0x43 data 12 in
         res 40/00:03:00:00:20/00:00:00:00:00/b0 Emask 0x4 (timeout)
ata2: soft resetting port
ata2.01: configured for UDMA/33
ata2: EH complete
ata2.01: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata2.01: cmd a0/00:00:00:00:20/00:00:00:00:00/b0 tag 0 cdb 0x43 data 12 in
         res 40/00:03:00:00:20/00:00:00:00:00/b0 Emask 0x4 (timeout)
ata2: soft resetting port
ata2.01: configured for UDMA/33
ata2: EH complete
ata2.01: limiting speed to UDMA/25:PIO4
ata2.01: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata2.01: cmd a0/00:00:00:00:20/00:00:00:00:00/b0 tag 0 cdb 0x43 data 12 in
         res 40/00:03:00:00:20/00:00:00:00:00/b0 Emask 0x4 (timeout)
ata2: soft resetting port
ata2.01: configured for UDMA/25
ata2: EH complete
sd 1:0:0:0: [sdb] READ CAPACITY failed
sd 1:0:0:0: [sdb] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK,SUGGEST_OK
sd 1:0:0:0: [sdb] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK,SUGGEST_OK
sd 1:0:0:0: [sdb] Sense not available.

The CD drive throws an error, then error recovery goes nuts apparently.
It eventually falls all the way down to PIO0 and then fails the drives
completely...

Can you try disconnecting that Lite-On drive, making the hard drive
master/only on its cable?
Comment 3 Andy Lawrence 2007-08-06 19:12:45 EDT
Chuck, that solved the lock ups!  After some time I did receive this:

hda-intel: Invalid position buffer, using LPIB read method instead.

That CD Burner "appeared" to function normally.  Let me know if you'd like me to
stab it back in for additional debug.  Otherwise I'll simply leave it out till
Recovery has fully recovered!!

Comment 4 Christopher Brown 2007-09-25 05:53:06 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am closing this bug as it appears resolved. If I have erred, please accept my
profuse apologies and re-open and I will attempt to assist in its resolution.

Note You need to log in before you can comment on or make changes to this bug.