Bug 251081 - Corruption of passwd
Summary: Corruption of passwd
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-users (Show other bugs)
(Show other bugs)
Version: 7
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-06 23:08 UTC by ray hammond
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 1.2.64-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-18 03:20:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ray hammond 2007-08-06 23:08:48 UTC
Description of problem:
Colon character permitted

Version-Release number of selected component (if applicable):
1.2.60

How reproducible:
Everytime

Steps to Reproduce:
1. Start the system-config-users utility from the Gnome menu
2. Select add new user button
3. Enter the user name as TEST
4. Enter a password of 123456 in both fields
5. Enter a colon as the first character in the path field and press OK
 
Actual results:
The user creates; but, the passwd file is messed up.

Expected results:
The colon character should be rejected.  Other fields i.e. the User name stop 
the colon character. 


Additional info:

I think the colon character is only accepted when input as the first character 
of the home directory or the shell path.  Now that passwd is corrupt the system-
config-user utility no longer loads.  The detail above may not be 100% accurate 
as I am locked out, due to passwd being corrupt.  I have tried to remeber the 
steps from memory.  When I am backup I will double check and repeat the test.

Comment 1 Nils Philippsen 2007-08-07 13:05:24 UTC
fixed in upstream Hg repository

Comment 2 Nils Philippsen 2007-08-07 13:11:54 UTC
BTW: username stops a colon as the first character only due to another different
check.

Comment 3 Fedora Update System 2007-08-17 16:12:35 UTC
system-config-users-1.2.64-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Fedora Update System 2007-09-18 03:20:17 UTC
system-config-users-1.2.64-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.