Bug 251162 - perl-DBD-MySQL - 2.9004 to 4.005
perl-DBD-MySQL - 2.9004 to 4.005
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: perl-DBD-MySQL (Show other bugs)
4.5
All Linux
low Severity low
: ---
: ---
Assigned To: Marcela Mašláňová
desktop-bugs@redhat.com
:
Depends On:
Blocks: 251170 360501
  Show dependency treegraph
 
Reported: 2007-08-07 11:27 EDT by Kevin Krafthefer
Modified: 2008-04-16 07:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-16 07:18:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Krafthefer 2007-08-07 11:27:49 EDT
Description of problem:
perl-DBI is being upgraded

Version-Release number of selected component (if applicable):
perl-DBD-MySQL - 2.9004 to 4.005

reference: bz250261
Comment 4 Jan Lieskovsky 2007-11-05 02:30:22 EST
Attaching testing result (as part of the 2007:0844):

Have finally prepared the testcase for the MySQL database and its perl-DBI
backend. Seems that there is something broken in the new packages. Attaching
more details:

The old perl-DBI-MySQL packages (perl-DBD-MySQL-2.9004-3.1):

1, service mysqld start
Starting MySQL:                                            [  OK  ]

2, mysql -u root mysql
. . .
mysql> GRANT ALL PRIVILEGES ON *.* TO 'iankko'@'localhost' IDENTIFIED BY
'iankko' WITH GRANT OPTION;     (ie. adding user iankko to be able to 
connect to the Mysql db from the localhost)

3, My testing script is called test.pl (contains some table creation,
   table drop, select SQL queries (will add update and delete SQL queries).
   But from this time. Here is the correct output:


# ./test.pl
Opening the connection to the database...
Successfully connected to the database: test
Creating tables: user, architecture, release, package and bug...
Performing SQL query:
 CREATE TABLE user(id SMALLINT UNSIGNED NOT NULL AUTO_INCREMENT, name
VARCHAR(20) CHARACTER SET utf8, surname VARCHAR(20) CHARACTER SET utf8, role
ENUM('reviewer','corrector','admin') CHARACTER SET utf8, PRIMARY KEY (id),
FULLTEXT (surname))   [ OK ]
Performing SQL query:
 CREATE TABLE architecture(id SMALLINT UNSIGNED NOT NULL AUTO_INCREMENT, name
VARCHAR(10) CHARACTER SET utf8, description VARCHAR(20) CHARACTER SET utf8,
PRIMARY KEY (id), FULLTEXT (name))   [ OK ]
Performing SQL query:
 CREATE TABLE package(id SMALLINT UNSIGNED NOT NULL AUTO_INCREMENT, name
VARCHAR(30) CHARACTER SET utf8, description VARCHAR(300) CHARACTER SET utf8,
version VARCHAR(30) CHARACTER SET utf8, PRIMARY KEY (id), user_fk SMALLINT
UNSIGNED NOT NULL REFERENCES user(id), arch_fk SMALLINT UNSIGNED NOT NULL
REFERENCES architecture(id), rel_fk SMALLINT UNSIGNED NOT NULL REFERENCES
release(id), FULLTEXT (description))   [ OK ]
Performing SQL query:
 CREATE TABLE release(id SMALLINT UNSIGNED NOT NULL AUTO_INCREMENT, name
ENUM('RHEL-2.1','RHEL-3','RHEL-4','RHEL-5'), PRIMARY KEY (id));   [ OK ]
Performing SQL query:
 CREATE TABLE bug(id SMALLINT UNSIGNED NOT NULL AUTO_INCREMENT, bname
VARCHAR(30) CHARACTER SET utf8, bdescription VARCHAR(300) CHARACTER SET utf8,
PRIMARY KEY (id), pkg_fk SMALLINT UNSIGNED NOT NULL REFERENCES package(id),
FULLTEXT (bname,bdescription))   [ OK ]
Tables: user, architecture, package, release and bug successfully created.
Filling table user...
Performing SQL query: INSERT INTO user VALUES
(NULL,"Elena","Fuente",'reviewer');    [ OK ]
Performing SQL query: INSERT INTO user VALUES (NULL,"John","de Ripper",'admin');
[ OK ]
Performing SQL query: INSERT INTO user VALUES
(NULL,"Pedro","Gonzales",'corrector');    [ OK ]
Performing SQL query: INSERT INTO user VALUES (NULL,"Miguel","De
Cervantes",'reviewer');    [ OK ]
Performing SQL query: INSERT INTO user VALUES (NULL,"Gabriel","Garcia
Marquez",'admin');     [ OK ]
Filling table architecture...
Performing SQL query: INSERT INTO architecture VALUES (NULL,'i386','Intel 386
arch');    [ OK ]
Performing SQL query: INSERT INTO architecture VALUES (NULL,'ia64','64 bit Intel
arch');    [ OK ]
Performing SQL query: INSERT INTO architecture VALUES (NULL,'s390','IBM 31 bit
arch');    [ OK ]
Performing SQL query: INSERT INTO architecture VALUES (NULL,'s390x','IBM 64 bit
arch');    [ OK ]
Performing SQL query: INSERT INTO architecture VALUES (NULL,'ppc','SPARC arch');
[ OK ]
Performing SQL query: INSERT INTO architecture VALUES (NULL,'x86_64','64 bit
arch');    [ OK ]
Filling table release...
Performing SQL query: INSERT INTO release VALUES (NULL,'RHEL-2.1');    [ OK ]
Performing SQL query: INSERT INTO release VALUES (NULL,'RHEL-3');    [ OK ]
Performing SQL query: INSERT INTO release VALUES (NULL,'RHEL-4');    [ OK ]
Performing SQL query: INSERT INTO release VALUES (NULL,'RHEL-5');    [ OK ]
Filling table package...
Performing SQL query: INSERT INTO package VALUES (NULL,'httpd',"The Apache web
server",'2.2.3-7.el5.i386',1,1,1);    [ OK ]
Performing SQL query: INSERT INTO package VALUES (NULL,'openssl',"The openssl
suite",'0.9.8b-8.3.el5_0.2.i686',2,2,2);    [ OK ]
Performing SQL query: INSERT INTO package VALUES (NULL,'cyrus-imapd','The cyrus
MTA','2.3.7-1.1.el5.i386',1,2,1);    [ OK ]
Performing SQL query: INSERT INTO package VALUES (NULL,'pcre','Perl compatible
regex library','6.6-1.1.i386',2,1,2);    [ OK ]
Performing SQL query: INSERT INTO package VALUES (NULL,'openldap','The LDAP
service client and server','2.3.27-5.i386',3,3,3);    [ OK ]
Filling table bug...
Performing SQL query: INSERT INTO bug VALUES (NULL,'BZ#123456','http
crashes',1);    [ OK ]
Performing SQL query: INSERT INTO bug VALUES (NULL,'BZ#654321','openssl invalid
signature generation',2);    [ OK ]
Performing SQL query: INSERT INTO bug VALUES (NULL,'BZ#214365','cyrus-imapd
inproper user quota handling',3);    [ OK ]
Performing SQL query: INSERT INTO bug VALUES (NULL,'BZ#563421','The pcre library
crashes when supplying inproper regexes',4);    [ OK ]
Performing SQL query: INSERT INTO bug VALUES (NULL,'BZ#162534','The ldapsearch
hangs when /var/lib/ldap/db database corruption detected',5);    [ OK ]
Selecting data from user table...
Performing SQL query: SELECT id, name, surname FROM user WHERE role LIKE
'reviewer'    [ OK ]
Item #1: 1,Elena,Fuente
Item #2: 4,Miguel,De Cervantes
Selecting data from architecture table...
Performing SQL query: SELECT * FROM architecture WHERE description LIKE '%bit%' 
[ OK ]
Item #1: 2,ia64,64 bit Intel arch
Item #2: 3,s390,IBM 31 bit arch
Item #3: 4,s390x,IBM 64 bit arch
Item #4: 6,x86_64,64 bit arch
Performing SQL query: SELECT * FROM architecture WHERE name LIKE '%s390%'    [
OK ]
Item #1: 3,s390,IBM 31 bit arch
Item #2: 4,s390x,IBM 64 bit arch
Selecting data from release table...
Performing SQL query: SELECT * FROM release WHERE name LIKE '%RHEL%'    [ OK ]
Item #1: 1,RHEL-2.1
Item #2: 2,RHEL-3
Item #3: 3,RHEL-4
Item #4: 4,RHEL-5
Selecting data from package table...
Performing SQL query: SELECT * FROM package WHERE arch_fk = '1'    [ OK ]
Item #1: 1,httpd,The Apache web server,2.2.3-7.el5.i386,1,1,1
Item #2: 4,pcre,Perl compatible regex library,6.6-1.1.i386,2,1,2
Selecting data from bug table...
Performing SQL query: SELECT * FROM bug WHERE bname LIKE '%BZ#%'    [ OK ]
Item #1: 1,BZ#123456,http crashes,1
Item #2: 2,BZ#654321,openssl invalid signature generation,2
Item #3: 3,BZ#214365,cyrus-imapd inproper user quota handling,3
Item #4: 4,BZ#563421,The pcre library crashes when supplying inproper regexes,4
Item #5: 5,BZ#162534,The ldapsearch hangs when /var/lib/ldap/db database
corruption detected,5
Dropping tables user, architecture, release, package and bug...
Performing SQL query: DROP TABLE bug   [ OK ]
Performing SQL query: DROP TABLE release   [ OK ]
Performing SQL query: DROP TABLE package   [ OK ]
Performing SQL query: DROP TABLE architecture   [ OK ]
Performing SQL query: DROP TABLE user   [ OK ]
Tables: user, architecture, package, release and bug successfully dropped.
Closing the connection to the database...

As you can see, there are no errors and valid SQL queries are performed
as expected. Can provide the "test.pl" script for you if you need.

And now the output with the new perl-DBI-MySQL packages
(perl-DBD-MySQL-4.005-1.*):

1, Upgrade to the new packages:

    Preparing...                ###########################################
[100%]
   1:perl-DBI               ########################################### [ 17%]
   2:perl-DBD-MySQL         ########################################### [ 33%]
   3:perl-DBD-MySQL-debuginf########################################### [ 50%]
   4:perl-DBD-Pg            ########################################### [ 67%]
   5:perl-DBD-Pg-debuginfo  ########################################### [ 83%]
   6:perl-DBI-debuginfo     ########################################### [100%]

2, Check the status of the MySQL DB backend:

   # service mysqld status
mysqld (pid 29533) is running...

3, Run the testing script:

   # ./test.pl
Opening the connection to the database...
/usr/bin/perl: symbol lookup error:
/usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi/auto/DBD/mysql/mysql.so:
undefined symbol: DBIc_TRACE_LEVEL

Current result:
The same error can be seen on all 6 architectures -> NEED_DEV.

Expected result:
No errors reported. The SQL queries should run correctly as in the case
of old packages.
Comment 6 RHEL Product and Program Management 2008-02-01 14:03:56 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 7 Stepan Kasal 2008-04-16 07:18:01 EDT
perl-DBD-Pg-1.49 is available in Red Hat Enterprise Linux 5.
Because of incomaptible changes to the API, it does not seem feasible to upgrade
the perl-DBD-* modules in Red Hat Enterprise Linux 4.*.
(See also the discussion to bug 250261.)

Note You need to log in before you can comment on or make changes to this bug.