Bug 251180 - Build time warnings for gfs2 userland tools
Build time warnings for gfs2 userland tools
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs2-utils (Show other bugs)
5.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Feist
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-07 12:24 EDT by Robert Peterson
Modified: 2010-01-11 22:39 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0350
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 13:20:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (7.51 KB, patch)
2007-08-27 10:32 EDT, Robert Peterson
no flags Details | Diff
Patch for HEAD branch of CVS (8.34 KB, patch)
2007-10-11 16:15 EDT, Robert Peterson
no flags Details | Diff
Patch for RHEL5 branch of CVS (12.35 KB, patch)
2007-10-11 16:18 EDT, Robert Peterson
no flags Details | Diff

  None (edit)
Description Robert Peterson 2007-08-07 12:24:06 EDT
I'm cloning this bug to separate out the gfs changes from the gfs2
changes.

+++ This bug was initially created as a clone of Bug #245573 +++

Hi Robert,

as we discussed on IRC. could you please fix the build time warning for gfs/gfs2
userland (both RHEL5 and HEAD)

Thanks
Fabio
Comment 1 Robert Peterson 2007-08-27 10:32:07 EDT
Created attachment 173601 [details]
Proposed patch

This patch eliminates the useless "pa" function and cleans up the
warnings in gfs2 userland.  Let me know if this is good enough.
Comment 2 Robert Peterson 2007-10-09 12:58:35 EDT
Requesting ack flags from the various departments.  This fix is a few
small, safe changes to the code, but I'd like to get them out of the
way before I move on to bug #325151, which is fairly serious.
Comment 3 Robert Peterson 2007-10-11 16:15:50 EDT
Created attachment 224721 [details]
Patch for HEAD branch of CVS

Here is my final patch for the HEAD branch in CVS, soon to be committed.
Comment 4 Robert Peterson 2007-10-11 16:18:24 EDT
Created attachment 224731 [details]
Patch for RHEL5 branch of CVS

This is slightly different from the HEAD patch because HEAD has 
been moving forward and therefore has differences.
Comment 5 Robert Peterson 2007-10-11 16:34:48 EDT
Code was tested on i386 on system trin-10.  Code was tested on x86_64
on system roth-01.  Patches were committed to HEAD and RHEL5 branches
for inclusion in 5.2.  Changing status to modified.
Comment 8 errata-xmlrpc 2008-05-21 13:20:01 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0350.html

Note You need to log in before you can comment on or make changes to this bug.