Bug 251183 - When Activation Keys -> Groups is clicked, traceback about Can't locate object method "server_group_list" via package "RHN::ServerGroup" is thrown
When Activation Keys -> Groups is clicked, traceback about Can't locate objec...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
500
All Linux
low Severity low
: ---
: ---
Assigned To: Miroslav Suchý
Preethi Thomas
/network/account/activation_keys/grou...
:
: 251182 (view as bug list)
Depends On:
Blocks: 248627
  Show dependency treegraph
 
Reported: 2007-08-07 12:43 EDT by Jan Pazdziora
Modified: 2010-10-22 13:18 EDT (History)
1 user (show)

See Also:
Fixed In Version: sat510
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 20:21:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2007-08-07 12:43:27 EDT
Description of problem:

When Activation Keys -> Groups is clicked, traceback about Can't locate object
method "server_group_list" via package "RHN::ServerGroup" is thrown.

Version-Release number of selected component (if applicable):

Satellite 5.0.0 GA.

How reproducible:

Nondeterministic, see below.

Steps to Reproduce:
1. Restart httpd on the Satellite, to clear mod_perl of any loaded moodule.
2. Go directly to Systems -> Activation Keys -> select a key -> Groups.
  
Actual results:

ISE 500 and traceback email which says

Error message:
  Can't locate object method "server_group_list" via package "RHN::ServerGroup"
(perhaps you forgot to load "RHN::ServerGroup"?) at
/usr/lib/perl5/site_perl/5.8.5/Snig
lets/ActivationKeys.pm line 251.

Expected results:

No error.

Additional info:

When you click on Systems -> System Groups (and you manage to do it with the
same httpd child and thus the same mod_perl interpreter), the Groups tab for
activation key starts to work.
Comment 1 Jan Pazdziora 2007-08-07 12:48:37 EDT
This is a low hanging fruit with solution offered directly in the error message
(use RHN::ServerGroup). I've verified that adding

   use RHN::ServerGroup ();

to Sniglets/ActivationKeys.pm indeed fixes the problem.

I therefore put this as an exception for 5.1.0. If 5.1.0 is already full and
closed, just punt it for 5.2.0.
Comment 2 Jan Pazdziora 2007-08-07 12:49:40 EDT
*** Bug 251182 has been marked as a duplicate of this bug. ***
Comment 7 Miroslav Suchý 2007-09-12 08:48:41 EDT
I'm taking over this bug. 
Commited into RELEASE-5.0 branch (rel. 131561).
Commited into trunk (rel. 131562)
Comment 8 Miroslav Suchý 2007-10-05 15:06:34 EDT
Moving ON_QA
Comment 9 Preethi Thomas 2007-10-16 12:14:27 EDT
verified
Comment 12 Issue Tracker 2008-02-07 09:54:04 EST
My bad, I was looking at my RHEL 5.1 schedule and scratching my head :)


This event sent from IssueTracker by cevich 
 issue 131842
Comment 14 Brandon Perkins 2008-04-02 20:21:19 EDT
5.1 Sat GA so Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.