Bug 251237 - kernel 2.6.22.1-41.fc7 fails to boot
Summary: kernel 2.6.22.1-41.fc7 fails to boot
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-07 21:27 UTC by David Anderson
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 2.6.22.5-76.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 22:00:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Anderson 2007-08-07 21:27:12 UTC
Description of problem: Kernel hangs whilst booting.

The last message displayed (having turned off quiet) is:

NET: Registered protocol family 2

If I boot the 2.6.21.1 kernel (which works), the next messages after the one 
above is:

Time: acpi_pm clocksource has been installed.
Switched to high resolution mode on CPU 0
Switched to high resolution mode on CPU 1

Version-Release number of selected component (if applicable): 2.6.22.1-41.fc7


How reproducible: Every time


Steps to Reproduce:
1. Boot

Actual results: Hangs
Expected results: Boots!

Additional info: Hardware: 
http://smolt.fedoraproject.org/show?UUID=d4941d87-b961-45b1-9e87-553aff506a23

Comment 1 Chuck Ebbert 2007-08-07 21:29:15 UTC
Try these kernel options alone and together:

  nolapic_timer
  nohz=off
  highres=off



Comment 2 David Anderson 2007-08-08 10:59:14 UTC
nolapic_timer fixes it. (The others don't).

Comment 3 Chuck Ebbert 2007-08-08 17:23:21 UTC
Looks like the fix for this has been found:

http://lkml.org/lkml/diff/2007/8/8/251/1


Note You need to log in before you can comment on or make changes to this bug.