Bug 251268 - PolicyKit-devel needs to have a Requires: glib2-devel
PolicyKit-devel needs to have a Requires: glib2-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: PolicyKit (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-07 20:20 EDT by Daniel Berrange
Modified: 2013-03-05 22:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-13 10:51:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2007-08-07 20:20:39 EDT
Description of problem:
Without the glib-devel package installed, its not possible to build against
PolicyKit, but this dependancy is missing in the -devel RPM for PolicyKit

# rpm -q PolicyKit-devel
PolicyKit-devel-0.5-0.git20070731.fc8

# pkg-config --libs polkit 
Package glib-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `glib-2.0.pc'
to the PKG_CONFIG_PATH environment variable
Package 'glib-2.0', required by 'polkit', not found


Version-Release number of selected component (if applicable):
PolicyKit-devel-0.5-0.git20070731.fc8


How reproducible:
Always

Steps to Reproduce:
1. Install PolicyKit-devel
2. Run pkg-config --libs  polkit
3.
  
Actual results:
Fails to find glib-2.0

Expected results:
Prints linker options

Additional info:
Comment 1 Daniel Berrange 2007-08-07 20:21:23 EDT
Opps, I meant  glib2-devel
Comment 2 Daniel Berrange 2007-08-07 20:22:53 EDT
Also seems to need  a dep on  dbus-devel for the polkit-dbus pkgconfig file
Comment 3 Matthias Clasen 2007-08-13 10:51:55 EDT
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.