Bug 251287 - Install of x86_64 installs too many 32bit libraries and packages
Install of x86_64 installs too many 32bit libraries and packages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
x86_64 Linux
high Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-08 03:04 EDT by Norm Murray
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-21 14:02:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Norm Murray 2007-08-08 03:04:32 EDT
Description of problem:
Ok... 64bit arches have been around for quite a while. Shouldn't we be able to
install a system which is pure 64bit at this point? 

This is especially painful when a 32 bit version of a package gets installed
without the 64 bit version of the same package - tools will not understand that
yum install fontconfig 
needs to do anything, when the 32 bit package is installed.
Comment 1 Jeremy Katz 2007-08-08 11:27:09 EDT
We install both arches of packages because that's the only way you get full use
of the hardware.  Doing a pure 64bit system means you might as well be using
ia64 ;-)

Realistically,  anaconda  is just going with distro policy -- until that changes,   
Comment 2 Wade Mealing 2007-08-08 19:51:39 EDT
Gday Jeremy,

I think that having this option would allow for simpler deployment and remove
many "wtf" moments, when one thinks they have the library installed.

Instead perhaps we should allow for a tickbox in anaconda 

[x] install only 64 bit packages ?

Sure, 32 bit packages can still be installed, but when one runs an entire open
source stack, running one arch makes things much easier.


Comment 3 Norm Murray 2007-08-09 00:08:15 EDT
Maybe it's too late already to try to get this to happen for f8, but this is
something we really need to work toward, and perhaps anaconda isn't the right
component (is there a policy component?)

Personal pain is that I spent a couple hours yesterday trying to figure out why
pkg-config was failing in a configure script when trying to rebuild gimp (really
I was wanting to build the development version of gimp, but the rebuild of
current shipping gimp was failing in the same way). 

32 bit fontconfig and fontconfig-devel were installed, so yum didn't know that
yum install fontconfig needed to do anything, so I had to manually sort out that
I had the wrong arch packages installed and install the correct ones. This was
set up by not having a pure 64bit system to start with - which should be the
default. 

Full use of the hardware is covered in 64 bit with the kernel so I'm really not
sure what you're attempting to allude to with your comment about ia64. 

At the very least there should be no 32 bit package able to be installed without
the 64 bit version of the package being installed and defaulted to for normal
operations. 
Comment 4 Jeremy Katz 2007-09-21 14:02:03 EDT
yum's behavior has changed so that if there are multiple arches of a package
available, it will let you still get the other arch in cases like yours above. 
And yum and anaconda should be consistent and not installing a 32bit package
without the 64bit one.  There were a few bugs in teh depsolver around test1 that
could lead to that occurring, but we've fixed those since.  

So this should be good

Note You need to log in before you can comment on or make changes to this bug.