Bug 251335 - New find-debuginfo.sh creates directory entries for /usr/lib/debug/
Summary: New find-debuginfo.sh creates directory entries for /usr/lib/debug/
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-08 13:44 UTC by Jan Kratochvil
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-08 18:33:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jan Kratochvil 2007-08-08 13:44:02 UTC
Description of problem:
New find-debuginfo.sh from Roland McGrath implemented in recent rpm creates IMO
inappropriate directory entries which weren't created previously.

Version-Release number of selected component (if applicable):
rpm-build-4.4.2.1-2.fc8.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. rpmbuild --rebuild /usr/src/rpm/SRPMS/hardlinked-1-0.fc7.src.rpm
2. rpm -qlvp /usr/src/rpm/RPMS/x86_64/hardlinked-*

Actual results:
-rwxr-xr-x    2 root    root             4016 Aug  8 15:30 /usr/bin/hardlinked
-rwxr-xr-x    2 root    root             4016 Aug  8 15:30 /usr/bin/hardlinked2
drwxr-xr-x    2 root    root                0 Aug  8 15:30 /usr/lib/debug
drwxr-xr-x    2 root    root                0 Aug  8 15:30 /usr/lib/debug/usr
drwxr-xr-x    2 root    root                0 Aug  8 15:30 /usr/lib/debug/usr/bin
-rwxr-xr-x    2 root    root             6024 Aug  8 15:30
/usr/lib/debug/usr/bin/hardlinked.debug
-rwxr-xr-x    2 root    root             6024 Aug  8 15:30
/usr/lib/debug/usr/bin/hardlinked2.debug
drwxr-xr-x    2 root    root                0 Aug  8 15:30 /usr/src/debug
drwxr-xr-x    2 root    root                0 Aug  8 15:30
/usr/src/debug/hardlinked-1
-rw-r--r--    1 root    root               32 Aug  8 15:19
/usr/src/debug/hardlinked-1/hardlinked.c

Expected results:
-rwxr-xr-x    2 root    root             4016 Aug  8 15:42 /usr/bin/hardlinked
-rwxr-xr-x    2 root    root             4016 Aug  8 15:42 /usr/bin/hardlinked2
-rwxr-xr-x    1 root    root             2528 Aug  8 15:42
/usr/lib/debug/usr/bin/hardlinked.debug
-rwxr-xr-x    1 root    root             6024 Aug  8 15:42
/usr/lib/debug/usr/bin/hardlinked2.debug
drwxr-xr-x    2 root    root                0 Aug  8 15:42
/usr/src/debug/hardlinked-1
-rw-r--r--    1 root    root               32 Aug  8 15:19
/usr/src/debug/hardlinked-1/hardlinked.c

Additional info:
Unaware if it negatively affects anything but it is IMO at least -debuginfo rpms
size inefficient.

Comment 1 Panu Matilainen 2007-08-08 13:50:51 UTC
Roland, care to have a look?

Comment 2 Roland McGrath 2007-08-08 18:21:29 UTC
This is an intentional and correct change.  Without those %dir lines, you are
left with /usr/lib/debug/bin et al directories after removing all debuginfo rpms.

What is the problem?

Comment 3 Jan Kratochvil 2007-08-08 18:33:37 UTC
There is no problem but it was a change since the former behavior and I expected
the original RPM had it right.
This bug was also for evaluation by the RPM owner.
Sorry for the bugreport.


Comment 4 Panu Matilainen 2007-08-09 06:56:15 UTC
Heh, I need new glasses or something, I somehow managed to see something in the
report that was not there... Yes, rpm's should own all the directories they
create, so this is a bug fixed, not introduced by the new script :) 


Note You need to log in before you can comment on or make changes to this bug.