This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 251392 - serial console for paravirt guests not working
serial console for paravirt guests not working
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: Xen Maintainance List
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-08 14:32 EDT by Gurhan Ozen
Modified: 2013-11-03 20:33 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-10 11:32:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gurhan Ozen 2007-08-08 14:32:37 EDT
Description of problem:
  After booting guests kernels with "console=tty0 console=xvc0" arguments, the
{virsh,xm} console domId commands seem to go nowhere. 
 
Version-Release number of selected component (if applicable):
# rpm -q kernel-xen libvirt xen
kernel-xen-2.6.18-37.el5
libvirt-0.2.3-5.el5
libvirt-0.2.3-5.el5
xen-3.0.3-33.el5


How reproducible:
Everytime.

Steps to Reproduce:
1. Create a paravirt guest. 
2. Boot it up with console=xvc0 console=tty0 arguments in the kernel line
3. Try to connect to the domain with virsh console or xm console.
  
Actual results:
Can't get serial port output.

Expected results:
Should have it. 

Additional info:
Comment 1 Daniel Berrange 2007-08-08 14:45:15 EDT
What guest kernel are you running ?

The kernel-xen-2.6.18-36.el5  kernel run as a guest works just fine, without any
 'console' args, or with 'console=xvc0 console=tty0', or with 'console=tty0
console=xvc0'. Supplying any console arg is completely redundant anyway, because
RHEL-5.1 guest kernels 'do the right thing' out of the box .
Comment 2 Daniel Berrange 2007-08-08 14:47:52 EDT
Please also provide the guest config file from /etc/xen  and the
/var/log/xen/xend.log
Comment 3 Gurhan Ozen 2007-08-10 11:32:41 EDT
This was an -EUSERERROR it looks like. I had "console=xvc0 console=tty0" as
opposed to "console=tty0 console=xvc0" which caused the problem. Having the
console args in right order fixed it. 

Note You need to log in before you can comment on or make changes to this bug.