Bug 251407 - Network device doesn't work in 32-bit Vista HVM guests
Network device doesn't work in 32-bit Vista HVM guests
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Herbert Xu
Virtualization Bugs
:
: 253486 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-08 15:22 EDT by Daniel Berrange
Modified: 2009-12-14 16:11 EST (History)
2 users (show)

See Also:
Fixed In Version: RHEA-2007-0635
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 12:11:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2007-08-08 15:22:42 EDT
Description of problem:
There have been a number of messages on community mailing lists saying Xen 3.1
HVM networking does not work with Vista. Upstream XenSource have just confirmed
this:

http://lists.xensource.com/archives/html/xen-devel/2007-08/msg00150.html

"32bit Vista's RX path didn't work at all with the emulated rtl8139 before about
three weeks ago (cset 15596 of xen-unstable)."

changeset:   15596:d99903a98ad0
user:        Tim Deegan <Tim.Deegan@xensource.com>
date:        Mon Jul 16 14:28:54 2007 +0100
files:       tools/ioemu/hw/rtl8139.c
description:
[HVM] Qemu rtl8139: correct rx CRC calculation
Signed-off-by: Tim Deegan <Tim.Deegan@xensource.com>


We need to double check this in RHEL-5.1 since our QEMU binary is based on Xen
3.1 and thus does *not* have this fix.

Version-Release number of selected component (if applicable):
Any xen prior to changeset 15596

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Daniel Berrange 2007-08-08 15:30:37 EDT
Apparently we may also need the preceeding changeset too

changeset:   15595:1158b6115b14
user:        Tim Deegan <Tim.Deegan@xensource.com>
date:        Mon Jul 16 14:27:12 2007 +0100
files:       tools/ioemu/hw/rtl8139.c
description:
[HVM] Qemu rtl8139: correct ring-buffer wrapping.
The rx DMA should never overrun when it hits the end of a 64k buffer
Signed-off-by: Tim Deegan <Tim.Deegan@xensource.com>
Comment 8 Daniel Berrange 2007-08-16 20:27:46 EDT
Built new RPM with fix to dist-5E-qu-candidate

* Thu Aug 16 2007 Daniel P. Berrange <berrange@redhat.com> - 3.0.3-36.el5
- Fix rtl8139 checksums for VISTA (rhbz #251407)

Comment 10 Chris Lalancette 2007-08-20 09:45:51 EDT
*** Bug 253486 has been marked as a duplicate of this bug. ***
Comment 12 errata-xmlrpc 2007-11-07 12:11:20 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0635.html

Note You need to log in before you can comment on or make changes to this bug.