Bug 251409 - Wrong setting for PEGASUS_DEST_LIB_DIR in SDKEnvVar.mak
Wrong setting for PEGASUS_DEST_LIB_DIR in SDKEnvVar.mak
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tog-pegasus (Show other bugs)
5.1
ia64 Linux
low Severity high
: ---
: ---
Assigned To: Vitezslav Crhonek
: OtherQA
: 250710 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-08 15:34 EDT by Denise Eckstein
Modified: 2009-06-19 19:59 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0522
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 11:48:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed Changes to SDKEnvVar.mak (2.26 KB, patch)
2007-08-08 15:40 EDT, Denise Eckstein
no flags Details | Diff

  None (edit)
Description Denise Eckstein 2007-08-08 15:34:41 EDT
Description of problem:
For ia64 platforms the PEGASUS_DEST_LIB_DIR is set to "/usr/lib64" instead 
of "/usr/lib" and the PEGASUS_PROVIDER_LIB_DIR is set 
to "/usr/lib64/Pegasus/providers" instead of "/usr/lib/Pegasus/providers". 

Version-Release number of selected component (if applicable):
tog-pegasus-devel-2.6.0-4.el5

How reproducible:
This problem is consistently reproducible on ia64 platforms.

Steps to Reproduce:
1. rpm -ih tog-pegasus-devel-2.6.0-4.el5.ia64.rpm 
2. cd /usr/share/Pegasus/samples
3. make
  
Actual results:
make[3]: Entering directory 
`/usr/share/Pegasus/samples/Providers/DefaultC++/InstanceProvider'
g++ -c -o /usr/share/Pegasus/samples/obj/InstanceProviderMain.o  -O2 -W -Wall -
Wno-unused -D_GNU_SOURCE -DTHREAD_SAFE -D_REENTRANT -fPIC \
             -I /usr/include -DPEGASUS_PLATFORM_LINUX_IA64_GNU 
InstanceProviderMain.cpp
g++ -c -o /usr/share/Pegasus/samples/obj/InstanceProvider.o  -O2 -W -Wall -Wno-
unused -D_GNU_SOURCE -DTHREAD_SAFE -D_REENTRANT -fPIC \
             -I /usr/include -DPEGASUS_PLATFORM_LINUX_IA64_GNU 
InstanceProvider.cpp
g++ -shared -Xlinker -rpath -Xlinker /usr/lib64  -
DPEGASUS_PLATFORM_LINUX_IA64_GNU \
             -
o/usr/share/Pegasus/samples/lib/libSDKInstanceProvider.so /usr/share/Pegasus/sa
mples/obj/InstanceProviderMain.o /usr/share/Pegasus/samples/obj/InstanceProvide
r.o -ldl -lpthread -lcrypt \
             -L/usr/lib64 -lpegcommon -L/usr/lib64 -lpegprovider 
make -i unlink
make[4]: Entering directory 
`/usr/share/Pegasus/samples/Providers/DefaultC++/InstanceProvider'
rm -f /usr/lib64/Pegasus/providers/libSDKInstanceProvider.so
make[4]: Leaving directory 
`/usr/share/Pegasus/samples/Providers/DefaultC++/InstanceProvider'
ln -f -
s /usr/share/Pegasus/samples/lib/libSDKInstanceProvider.so /usr/lib64/Pegasus/p
roviders/libSDKInstanceProvider.so
ln: creating symbolic link 
`/usr/lib64/Pegasus/providers/libSDKInstanceProvider.so' to 
`/usr/share/Pegasus/samples/lib/libSDKInstanceProvider.so': No such file or 
directory
make[3]: *** [/usr/share/Pegasus/samples/lib/libSDKInstanceProvider.so] Error 1
make[3]: Leaving directory 
`/usr/share/Pegasus/samples/Providers/DefaultC++/InstanceProvider'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/usr/share/Pegasus/samples/Providers/DefaultC++'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/usr/share/Pegasus/samples/Providers'
make: *** [all] Error 2


Expected results:
make -i unlink
make[4]: Entering directory 
`/usr/share/Pegasus/samples/Providers/CMPI/CWS_Util'
rm -f /usr/lib/Pegasus/providers/libSDKcmpiCWS_Util.so
make[4]: Leaving directory `/usr/share/Pegasus/samples/Providers/CMPI/CWS_Util'
ln -f -
s /usr/share/Pegasus/samples/lib/libSDKcmpiCWS_Util.so /usr/lib/Pegasus/provide
rs/libSDKcmpiCWS_Util.so
make[3]: Leaving directory `/usr/share/Pegasus/samples/Providers/CMPI/CWS_Util'
make[3]: Entering directory 
`/usr/share/Pegasus/samples/Providers/CMPI/FilesAndDirectories'
gcc -c -o /usr/share/Pegasus/samples/obj/CWS_PlainFile.o -O2 -W -Wall -Wno-
unused -D_GNU_SOURCE -DTHREAD_SAFE -D_REENTRANT -fPIC \
             -I /usr/include -DPEGASUS_PLATFORM_LINUX_IA64_GNU CWS_PlainFile.c
gcc -c -o /usr/share/Pegasus/samples/obj/CWS_FileUtils.o -O2 -W -Wall -Wno-
unused -D_GNU_SOURCE -DTHREAD_SAFE -D_REENTRANT -fPIC \
             -I /usr/include -DPEGASUS_PLATFORM_LINUX_IA64_GNU CWS_FileUtils.c
gcc -c -o /usr/share/Pegasus/samples/obj/CWS_Directory.o -O2 -W -Wall -Wno-
unused -D_GNU_SOURCE -DTHREAD_SAFE -D_REENTRANT -fPIC \
             -I /usr/include -DPEGASUS_PLATFORM_LINUX_IA64_GNU CWS_Directory.c
gcc -c -o /usr/share/Pegasus/samples/obj/CWS_DirectoryContainsFile.o -O2 -W -
Wall -Wno-unused -D_GNU_SOURCE -DTHREAD_SAFE -D_REENTRANT -fPIC \
             -I /usr/include -DPEGASUS_PLATFORM_LINUX_IA64_GNU 
CWS_DirectoryContainsFile.c
g++ -shared -Xlinker -rpath -Xlinker /usr/lib  -
DPEGASUS_PLATFORM_LINUX_IA64_GNU \
             -
o/usr/share/Pegasus/samples/lib/libSDKFilesAndDirectories.so /usr/share/Pegasus
/samples/obj/CWS_PlainFile.o /usr/share/Pegasus/samples/obj/CWS_FileU
tils.o /usr/share/Pegasus/samples/obj/CWS_Directory.o /usr/share/Pegasus/sample
s/obj/CWS_DirectoryContainsFile.o -ldl -lpthread -lcrypt \
             -L/usr/lib -lSDKcmpiCWS_Util -L /usr/share/Pegasus/samples/lib
make -i unlink
make[4]: Entering directory 
`/usr/share/Pegasus/samples/Providers/CMPI/FilesAndDirectories'
rm -f /usr/lib/Pegasus/providers/libSDKFilesAndDirectories.so
make[4]: Leaving directory 
`/usr/share/Pegasus/samples/Providers/CMPI/FilesAndDirectories'
ln -f -
s /usr/share/Pegasus/samples/lib/libSDKFilesAndDirectories.so /usr/lib/Pegasus/
providers/libSDKFilesAndDirectories.so
make[3]: Leaving directory 
`/usr/share/Pegasus/samples/Providers/CMPI/FilesAndDirectories'
make[2]: Leaving directory `/usr/share/Pegasus/samples/Providers/CMPI'
make[1]: Leaving directory `/usr/share/Pegasus/samples/Providers'


Additional info:
This bug is dependent on a fix to Bug 213809.
Comment 1 Denise Eckstein 2007-08-08 15:40:11 EDT
Created attachment 160930 [details]
Proposed Changes to SDKEnvVar.mak

Note: SDKEnvVar.mak is a generated file.  The actual changes would need to be
make in patch pegasus-2.6.0-multilib.patch.
Comment 2 Denise Eckstein 2007-08-15 16:43:54 EDT
In addition to the incorrect value for PEGASUS_DEST_LIB_DIR, the attached diff 
file identifies two syntax problems in the generated SDKEnvVar.mak file (1) a 
missing space between "ifeq" and "(" and (2) a missing endif.

Thanks,
Denise
Comment 3 Denise Eckstein 2007-08-15 16:47:41 EDT
*** Bug 250710 has been marked as a duplicate of this bug. ***
Comment 9 John Poelstra 2007-08-30 20:27:27 EDT
A fix for this issue should have been included in the packages contained in the
RHEL5.1-Snapshot4 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed *as soon as possible*
to ensure that it is included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message to Issue Tracker and
I will change the status for you.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 10 Denise Eckstein 2007-09-08 18:52:53 EDT
I'm still seeing all three problems in RHEL5.1-Snaphshot4.  I.e., (1) 
incorrect value for PEGASUS_DEST_LIB_DIR, (2) missing space between "ifeq" 
and "(" and (3) a missing endif.  The version of tog-pegasus packaged with 
Snapshot 4 is tog-pegasus-devel-2.6.1-1.el5 and tog-pegasus-2.6.1-1.el5.  It 
doesn't appear that the patch file has been changed.

-rw-r--r-- 1 root root    9168 Jun 22 06:26 pegasus-2.6.0-multilib.patch
Comment 11 John Poelstra 2007-09-08 19:51:57 EDT
changing to FAILS_QA per comment #10
Comment 12 David Kovalsky 2007-09-09 09:06:56 EDT
The latest build of tog-pegasus is tog-pegasus-2.6.1-2.el5. By a quick look into
CVS and the latest SRPM pegasus-2.6.0-multilib.patch has changed. 

Denise, can you please verify with tog-pegasus-2.6.1-2.el5 and see if that fixes
the issue?
Comment 13 Denise Eckstein 2007-09-09 11:20:16 EDT
Sure, but the lastest information I have is that the SnapShot 5 ISOs were not 
released to partners.  Is there somewhere I can get access to just the tog-
pegasus-2.6.1-2.el15 RPM?  The SRPM would be sufficient.
Comment 14 Vitezslav Crhonek 2007-09-10 07:04:25 EDT
Here you can find latest build:

http://people.redhat.com/vcrhonek/tog-pegasus-2.6.1-2.el5.src.rpm

Please check it.
Comment 15 John Poelstra 2007-09-11 15:19:36 EDT
A fix for this issue should have been included in the packages contained in the
RHEL5.1-Snapshot6 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed ASAP to confirm that it
will be included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message to Issue Tracker and
I will change the status for you.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 16 Denise Eckstein 2007-09-13 01:33:29 EDT
Verified that all three problems have been resolved in tog-pegasus-devel-2.6.1-
2.el5.
Comment 17 Denise Eckstein 2007-09-13 01:36:01 EDT
Thanks!
Comment 19 errata-xmlrpc 2007-11-07 11:48:14 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0522.html

Note You need to log in before you can comment on or make changes to this bug.