Bug 251424 - CRM #1630402 - Unable to delete old virtual guests from RHN
CRM #1630402 - Unable to delete old virtual guests from RHN
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn500
All Linux
medium Severity medium
: ---
: ---
Assigned To: Grant Gainey
Mike Orazi
/rhn/systems/details/virtualization/V...
:
Depends On:
Blocks: 246409
  Show dependency treegraph
 
Reported: 2007-08-08 18:33 EDT by Issue Tracker
Modified: 2010-10-22 13:23 EDT (History)
1 user (show)

See Also:
Fixed In Version: 5.0.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-02 12:38:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Issue Tracker 2007-08-08 18:33:54 EDT
Escalated to Bugzilla from IssueTracker
Comment 4 Grant Gainey 2007-08-09 08:12:45 EDT
Recreated in QA.  The desired behavior here is controlled by "Org has access to
management entitlements".  The IntegralGroup user has no Management entitlements
- so the option to select/delete old guests is missing.

The bug here is that the whole screen should be sensitive to "do I have
Management or not", not just the select-column - as it stands, this page is very
confusing.  Adding to 503-triage, as that's a straightforward change.

The issue of whether or not this behavior SHOULD be controlled by Management
access is one for Marketing/Sales, since that's where those decisions are made.

TEST PLAN:
1) Log in as a user with Virtualization entitlement and Management entitlement.
2) Create a number of guest systems on a host that has both Virt and Mgt.
3) Go to that host's SDC\Virtualization tab.
EXPECTED: Be allowed to select and delete guests.
4) Edit that system's properties and REMOVE Management
5) Return to SDC\Virtualization
EXPECTED: Verbiage about needing management entitlement to remove old guests.
EXPECTED: No opportunity to select guests.
EXPECTED: No action-submit.
Comment 5 Grant Gainey 2007-09-10 14:08:27 EDT
After discussion, the decision is to simply allow for seeing and deleting guests
on hosted regardless of entitlements.  Ignore the test-plan above, and replace with:

TEST PLAN:
1) Log in as a user with Virtualization entitlement and Management entitlement.
2) Create a number of guest systems on a host that has both Virt and Mgt.
3) Go to that host's SDC\Virtualization tab.
EXPECTED: Be allowed to select and delete guests.
4) Edit that system's properties and REMOVE Management
5) Return to SDC\Virtualization
EXPECTED: Be allowed to select and delete guests.
Comment 6 Grant Gainey 2007-09-11 08:58:31 EDT
Research shows that BOTH test plans are incorrect.  Current behavior is
controlled by the ORGANIZATION having at least one Management entitlement.

TEST PLAN:
1) Log in to RHN as user IntegralGroup (for DEV and QA password is the scrubbed
one, for STAGE we'll need to reset the pwd)
2) Examine System 'miami', go to its 'Virtualization' tab:
https://.../rhn/systems/details/virtualization/VirtualGuestsList.do?sid=1007400483

EXPECTED: You should see several virtual guests.
EXPECTED: You should be able to SELECT a guest and then choose 'Delete Selected
Guests'
EXPECTED: You should see the delete-confirm page, showing the virt-guest you
selected.

(Note: it is not necessary to continue the delete)
Comment 7 Grant Gainey 2007-09-11 09:37:00 EDT
Checked in for both trunk and 503

Note You need to log in before you can comment on or make changes to this bug.