Bug 251438 - IG no longer builds in DocBot
Summary: IG no longer builds in DocBot
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Installation_Guide   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: Don Domingo
QA Contact: Content Services Development
URL:
Whiteboard:
Keywords: Documentation
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-09 02:24 UTC by Yulia
Modified: 2016-06-05 23:36 UTC (History)
1 user (show)

Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-21 00:12:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Yulia 2007-08-09 02:24:41 UTC
Description of problem:
It is all started when I wanted to apply some corrections to IG and ended up not
being able to rebuild it.
Tried other languages, same result.

Log extract:

Kickstart2.xml:961: element varlistentry: validity error : Element varlistentry
content does not follow the DTD, expecting (term+ , listitem), got (term )
Kickstart2.xml:964: element varlistentry: validity error : Element varlistentry
content does not follow the DTD, expecting (term+ , listitem), got (term )
Kickstart2.xml:967: element varlistentry: validity error : Element varlistentry
content does not follow the DTD, expecting (term+ , listitem), got (term )
Kickstart2.xml:970: element varlistentry: validity error : Element varlistentry
content does not follow the DTD, expecting (term+ , listitem), got (term )


Indeed, we have <term> tags in the PO files but that's about it. Nothing like
<listitem> or <varlistentry>. Looks like when the PO is converted into XML, it
can not be validated because expected <listitem> is missing.

Who would be the right person to look into that?

Thank you in advance,
Yulia

Comment 1 Don Domingo 2007-08-09 03:01:44 UTC
discussed in person with reporter; Yulia will try fully translating
Kickstart2.xml before trying build again. will await results.

incidentally, Kickstart2.xml isn't the only file in the entire module that uses
"<variablelist>", and it definitely isn't the only one that uses "<listitem>"
(nearly every source file has it), so if this is a Docbot issue then i figure it
should affect all files that contain lists and variablelists. 

more to come... 

Comment 2 Yulia 2007-08-09 05:28:36 UTC
Updated the PO file Kickstart2.po
IG now 100% completed.

Yet same result with the same error :/

Yulia


Comment 3 Don Domingo 2008-01-21 00:12:36 UTC
IG now builds in Docbot. closing this bug.


Note You need to log in before you can comment on or make changes to this bug.