Bug 251456 - pppoe-server error in RHEL5 [NEEDINFO]
pppoe-server error in RHEL5
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ppp (Show other bugs)
5.0
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Skala
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-09 02:48 EDT by Xiao Shaocong
Modified: 2014-11-09 17:30 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:09:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mnagy: needinfo? (xiao.shaocong)


Attachments (Terms of Use)

  None (edit)
Description Xiao Shaocong 2007-08-09 02:48:46 EDT
Description of problem:
RHEL5 Seting pppoe-server error

Version-Release number of selected component (if applicable):
rp-pppoe-3.5-32.1

How reproducible:


Steps to Reproduce:
1、vim /etc/ppp/pap-secrets
luo	*	"123456"	*

2、vim /etc/ppp/pppoe-server-options
add“#” before all line

3、vim /etc/ppp/options
local
lock

4、execute command:
pppoe-server -L 192.168.0.1 -R 192.168.0.100 -N 10

I can seting this in RHEL4.4
  
Actual results:
Aug  9 15:03:18 node2 pppoe-server[6853]: Session 2 created for client
00:0c:29:a7:ca:a0 (172.16.112.151) on eth0 using Service-Name ''
Aug  9 15:03:18 node2 pppd[6853]: pppd 2.4.4 started by root, uid 0
Aug  9 15:03:19 node2 pppd[6853]: Using interface ppp0
Aug  9 15:03:19 node2 pppd[6853]: Connect: ppp0 <--> /dev/pts/1
Aug  9 15:03:50 node2 pppoe-server[6764]: PADT: Generic-Error: RP-PPPoE: System
call error: Input/output error
Aug  9 15:03:50 node2 pppoe-server[6764]: Sent PADT
Aug  9 15:03:50 node2 pppd[6853]: Terminating on signal 15
Aug  9 15:03:56 node2 pppd[6853]: Connection terminated.
Aug  9 15:03:56 node2 pppd[6853]: Modem hangup
Aug  9 15:04:01 node2 pppd[6853]: Exit.


Expected results:


Additional info:
Comment 1 Florin Popovici 2007-11-24 12:59:57 EST
It's probably the same bug as 222295.
Check https://bugzilla.redhat.com/show_bug.cgi?id=222295, there's a workaround.
Comment 2 Ngo Than 2008-05-13 11:56:15 EDT
it looks like a bug in ppp. reassign to correct component
Comment 3 Martin Nagy 2008-05-13 12:05:54 EDT
Can you try the patch from https://bugzilla.redhat.com/attachment.cgi?id=269351
if it helps?
Comment 4 Jiri Skala 2008-08-11 09:20:34 EDT
The solution of #443914 fixes also this bug. It works fine.
Comment 5 RHEL Product and Program Management 2008-08-11 09:23:17 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 11 errata-xmlrpc 2009-01-20 16:09:27 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0111.html

Note You need to log in before you can comment on or make changes to this bug.