Bug 251489 - The graphical console is not displayed, when VM is created by the same name twice in virt-manager
The graphical console is not displayed, when VM is created by the same name t...
Status: CLOSED DUPLICATE of bug 249094
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.1
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On: 246198
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-09 08:56 EDT by Sachin Prabhu
Modified: 2009-12-14 16:15 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-09 08:58:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachin Prabhu 2007-08-09 08:56:09 EDT
+++ This bug was initially created as a clone of Bug #246198 +++

Description of problem:
A graphical console is not displayed, when VM is created by the same name 
twice in virt-manager.
And the following error messages are displayed on the console.

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 578, in finish
    vm = self.connection.get_vm(guest.uuid)
  File "/usr/share/virt-manager/virtManager/connection.py", line 200, in get_vm
    return self.vms[uuid]
KeyError: 'b60d0a97-810a-dd72-68e0-88f334d11635'


Version-Release number of selected component (if applicable):
Changeset:216f03a53d2b

How reproducible:
Always

Steps to Reproduce:
1. Set [Automativally open console] to [For new domains]
2. Create VM pushing [New] button
3. Close a graphical console after it is displayed
4. Stop the VM without installing the OS
5. Delete the VM
6. Create VM of the name same as VM which created first

Actual results:
The graphical console is not displayed.

Expected results:
The graphical console is displayed.

Additional info:
 - Hypervisor is Xen.
Comment 1 Daniel Berrange 2007-08-09 08:58:18 EDT
*** This bug has been marked as a duplicate of 249094 ***

*** This bug has been marked as a duplicate of 249094 ***
Comment 2 Issue Tracker 2007-08-09 09:12:52 EDT
problem fixed in package

virt-manager-0.4.0-3.el5

Internal Status set to 'Waiting on SEG'

This event sent from IssueTracker by sprabhu 
 issue 128655

Note You need to log in before you can comment on or make changes to this bug.