Bug 251505 - Allow multiple simultaneous esound instances
Summary: Allow multiple simultaneous esound instances
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: esound (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-09 14:17 UTC by Lennart Poettering
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 1:0.2.38-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-20 14:03:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (1.06 KB, patch)
2007-08-09 14:17 UTC, Lennart Poettering
no flags Details | Diff

Description Lennart Poettering 2007-08-09 14:17:58 UTC
Please merge the patch I attached into the fedora esd packages. It is already
being shipped that way by Ubuntu. It moves the esd socket from /tmp/.esd/socket
to /tmp/.esd-`id -u`/socket, effectively allowing multiple simultaneous esd
instances, one per user.

I need this for getting fast-user-switching working properly in PulseAudio,
because otherwise when multiple PA instances are running only a single one would
be able to emulate esd.

Comment 1 Lennart Poettering 2007-08-09 14:17:58 UTC
Created attachment 160976 [details]
patch

Comment 2 Bastien Nocera 2007-08-09 14:29:12 UTC
Looks good, please push in rawhide.

Also make sure you create an upstream bug and CC: me on it.

Comment 3 Lennart Poettering 2007-08-09 15:18:49 UTC
Posted upstream:

http://bugzilla.gnome.org/show_bug.cgi?id=465067


Note You need to log in before you can comment on or make changes to this bug.