Bug 25154 - 2 video cards and text install
Summary: 2 video cards and text install
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 7.0
Hardware: i686
OS: Linux
high
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 25153 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-28 19:20 UTC by Need Real Name
Modified: 2005-10-31 22:00 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-01-30 00:20:57 UTC


Attachments (Terms of Use)

Description Need Real Name 2001-01-28 19:20:50 UTC
I have 2 video cards: agp ati all-in-wonder128 16mb and a 3dfx voodoo3 3000
pci 16mb.

When I run 7's installer, it uses the ncurses install.  My guess it that it
is stupid and can't figure out what to do.  When it goes to probe the video
card it comes back with voodoo3 3000 pci - and I say "Duh - that's my
non-primary card"  At this point in the install I can't do a damn thing
about it - back will let me go back and see this painful message again.  In
the bios I have AGP/PCI boot order so I don't understand how the installer
grabs the pci card first?  After finishing the install, the x config file
does have the dri and r128 driver.  Note that the voodoo3 card is not there
as a second display.  I think one solution is to have a menu pop asking is
this the right card - have buttons that says "no - let me pick", and "yes".

Another thing - how come the installer didn't just use a svga-vesa driver
for the install - if it did that then I could've installed with the nice
installer.  Or, there could be a fallback vga-16 color 640x480 driver that
would be used if the installer can't figure out the video card.

Comment 1 Michael Fulbright 2001-01-30 00:20:53 UTC
We have as a future feature the ability to handle this (admittedly rare) case
differently.

For now just remove one card, install, and then things should be fine. You can
put the secondary card back in once you have the system upgraded.


Comment 2 Michael Fulbright 2001-01-30 00:21:14 UTC
*** Bug 25153 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.