Bug 251566 - Trouble with booting 2.6.18-37.el5xen kernel on a Dell PowerEdge machine
Trouble with booting 2.6.18-37.el5xen kernel on a Dell PowerEdge machine
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-09 15:40 EDT by Gurhan Ozen
Modified: 2013-11-03 20:33 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-25 08:53:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xen kernel boot. (5.56 KB, text/plain)
2007-08-09 15:40 EDT, Gurhan Ozen
no flags Details
dmidecode on the machine (18.26 KB, text/plain)
2007-08-09 15:46 EDT, Gurhan Ozen
no flags Details
cpuinfo from the box (2.43 KB, text/plain)
2007-08-09 15:54 EDT, Gurhan Ozen
no flags Details
lspci info from the machine (3.00 KB, text/plain)
2007-08-09 15:55 EDT, Gurhan Ozen
no flags Details
meminfo of the machine (777 bytes, text/plain)
2007-08-09 15:56 EDT, Gurhan Ozen
no flags Details
xen kernel boot log (16.20 KB, text/plain)
2007-08-09 16:07 EDT, Gurhan Ozen
no flags Details
boot log from non-xen kernel (20.09 KB, text/plain)
2007-08-09 16:15 EDT, Gurhan Ozen
no flags Details

  None (edit)
Description Gurhan Ozen 2007-08-09 15:40:13 EDT
This might be hardware-specific, as this kernel most certainly was able to boot
on other machines. When, however, tried this kernel on a Dell PowerEdge 1950
machine, the xen kernel didn't boot whereas the non-xen kernel did. The last
line of the boot messages is :
  request_module: runaway loop modprobe binfmt-464c

I am attaching the boot messages from xen kernel and also various information
about the hardware i retrieve while it's booted into non-xen kernel. 

Version-Release number of selected component (if applicable):
2.6.18-37.el5xen.x86_64

How reproducible:
Everytime

Steps to Reproduce:
1. You'll need a Dell PowerEdge 1950 machine for this. There are two of them in
the lab, but alas neither has remote access set up. You can use them if wanting
to test
2. Just boot with xen kernel
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Gurhan Ozen 2007-08-09 15:40:13 EDT
Created attachment 161010 [details]
xen kernel boot.
Comment 2 Daniel Berrange 2007-08-09 15:44:19 EDT
That kernel boot log is useless - please reboot *without* the 'quiet' option
specified for the kernel.
Comment 3 Daniel Berrange 2007-08-09 15:44:57 EDT
Can we also have a boot log from the non-Xen kernel for comparison - again with
the 'quiet' option
Comment 4 Gurhan Ozen 2007-08-09 15:46:41 EDT
Created attachment 161011 [details]
dmidecode on the machine
Comment 5 Gurhan Ozen 2007-08-09 15:54:15 EDT
Created attachment 161013 [details]
cpuinfo from the box
Comment 6 Gurhan Ozen 2007-08-09 15:55:19 EDT
Created attachment 161014 [details]
lspci info from the machine
Comment 7 Gurhan Ozen 2007-08-09 15:56:24 EDT
Created attachment 161015 [details]
meminfo of the machine
Comment 8 Gurhan Ozen 2007-08-09 16:07:37 EDT
Created attachment 161016 [details]
xen kernel boot log
Comment 9 Gurhan Ozen 2007-08-09 16:15:47 EDT
Created attachment 161019 [details]
boot log from non-xen kernel
Comment 10 Gurhan Ozen 2007-08-09 16:17:31 EDT
(In reply to comment #3)
> Can we also have a boot log from the non-Xen kernel for comparison - again with
> the 'quiet' option

Yes, i just attached both xen and non-xen kernel boot logs without the quiet
option. Sorry about the quiet option, sometimes i forget about such defaults.
Comment 11 Daniel Berrange 2007-08-09 16:25:31 EDT
Ok, so the kernel itself looks like its booting OK. The last set of messages

Freeing unused kernel memory: 168k freed
Write protecting the kernel read-only data: 360k
request_module: runaway loop modprobe binfmt-464c
request_module: runaway loop modprobe binfmt-464c
request_module: runaway loop modprobe binfmt-464c
request_module: runaway loop modprobe binfmt-464c
request_module: runaway loop modprobe binfmt-464c

Are right at the point where the initrd starts up. Normally you'd expect 

Freeing unused kernel memory: 192k freed
Write protecting the kernel read-only data: 469k
Red Hat nash version 5.1.19.6 starting

Have you experianced the same problem on multiple different machines / installs
 ? Or is it perhaps just a messed up in the initrd that needs rebuilding ?
Comment 12 Gurhan Ozen 2007-08-09 16:56:07 EDT
Hmm no, i haven't seen this anywhere else. I can try to install on another
identical machine or just re-install on the same machine. 
Rebuilt the initrd image but got the same result.
Comment 13 Chris Lalancette 2007-09-25 08:53:01 EDT
Gurhan,
     I just went through this with Dave Anderson.  I'm fairly certain what
happened here is that you installed an i686 kernel on an x86_64 machine.  I
would have expected it to actually blow up, but what it does is show the runaway
loop messages instead.  I've pushed an RFC to rhkernel-list to try to detect
this situation and at least warn about it.  Anyway, I'm pretty sure this isn't a
bug, so I'm going to close it as NOTABUG.  Re-open if you have problems.

Chris Lalancette

Note You need to log in before you can comment on or make changes to this bug.