Bug 251567 - pcmcia modules missing
pcmcia modules missing
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-09 15:41 EDT by Thomas Dodd
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 2.6.22.5-49.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 17:55:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Dodd 2007-08-09 15:41:28 EDT
The kernels for FC6 donot have the pcmcia driver modulas for older isa/non
cardbus sockets.

kernel-2.6.18-1.2798.fc6
kernel-2.6.20-1.2952.fc6
kernel-2.6.20-1.2962.fc6

At least done. The kernel config files show
# CONFIG_I82365 is not set
# CONFIG_TCIC is not set
from dmesg:
isapnp: Scanning for PnP cards...
isapnp: Card 'ACTIONTEC PNP PCMCIA ADAPTER'
isapnp: 1 Plug & Play card detected total

kudzu -p shows the socket on my desktop as:
class: SOCKET
bus: MISC
detached: 0
driver: i82365
desc: "Generic i82365-compatible PCMCIA controller"

Why are these modules not being built anymore?
Comment 1 Thomas Dodd 2007-08-10 14:01:50 EDT
Forgot to add, I had to turn on isapnp as well to get the socket configured at
all. It doesn't show up at all with the stock kernels.

Not having much luck building a kernel though. I really don't understand the
SElinux and xen stuff.
Comment 2 Chuck Ebbert 2007-08-10 17:23:00 EDT
?(In reply to comment #1)
> Forgot to add, I had to turn on isapnp as well to get the socket configured at
> all. It doesn't show up at all with the stock kernels.
> 

ISAPNP is enabled in our kernels. PNPBIOS is not, however.

What kind of machine is this? Maybe we can just add support for 82365 to the 586
kernel if that's what it is.
Comment 3 Thomas Dodd 2007-08-10 17:52:29 EDT
Not sure about the ISA thing now. I got distracted for a while.
But, after I booted the latest, non-xen kernel, kudzu doesn't show it and it's
not listed in the logs.

The machine is an 800 MHz SlotA Athlon (Thunderbird) on a MSI 6167 boar with an
AMD 750/751 chip set. I haven't found a PCI based PCMCIA socket that I liked
enough to upgrade the system. The Socket is an ACTIONTEC PC-700 (pn: AD70000-02)
<http://www.actiontec.com/support/readers/pc700.html>
I paid $65 for it in '98 and it still works (as do the other parts I bought then).


I don't boot from it, so If there's a user space tool to configure it (like the
old isapnp tools?) that's fine. But I still need the driver.


(I also had trouble when I tried to install FC6 on my Gatway Solo Pro 9300 which
has a yenta socket in the laptop and the docking station. Runs RHL9 fine, but
boot from CD didn't find the NIC for a network install. Of course a 600MHz PII
w/96MB isn't really enough for FC6 or 7 is it?)
Comment 4 Thomas Dodd 2007-08-10 17:57:01 EDT
Correction, it was in the xen kernel I guess, it is in the log with 2.6.22.1-32.fc6.
Comment 5 Thomas Dodd 2007-08-24 17:02:02 EDT
Maybe my last comment was missunderstood.

I see the listing in the kernel log for ISAPNP with the normal kernel, but not
the xen kernel.

Same for weather kudzu reports it or not.

But neither kernel has the i82365 module needed to use it.


So, how do I get the module I need? Why is it no longer built?

Is they documentation somewhere as to what packages to install for the kernel
source now, and how to build a custom kernel?

The last release I did stuff like this for was FC1, and much has changed since
then. I don't even understand teh point of XEN or SELinux yet.
Comment 6 Chuck Ebbert 2007-08-28 16:20:43 EDT
Driver added to the config, will be in the next build.

Docs for building a custom kernel are at:
http://fedoraproject.org/wiki/Docs/CustomKernel
Comment 7 Thomas Dodd 2007-08-29 18:27:40 EDT
Thank for the Docs. That worked.

No to figure out how to get the driver to load automatically....

Next build for the FC6 kernel, or for all kernels?
In other words, if I decide to update to FC7 or FC8 am I going to have this same
issue again, and need to build a custom kernel for every update?

Are there that few users that still need this module?
Does it save enough space to make it matter?
Comment 8 Chuck Ebbert 2007-08-29 18:43:54 EDT
(In reply to comment #7)
> Next build for the FC6 kernel, or for all kernels?
> In other words, if I decide to update to FC7 or FC8 am I going to have this same
> issue again, and need to build a custom kernel for every update?
> 

It's been enabled in FC6, F7 and rawhide (F8).

> Are there that few users that still need this module?
> Does it save enough space to make it matter?
> 

Probably it was disabled because it was thought nobody needed it anymore.

Comment 9 Thomas Dodd 2007-09-14 16:39:13 EDT
Thanks Chuck.

Working well.

Note You need to log in before you can comment on or make changes to this bug.