Bug 251572 - fancontrol: Kernel kernel-2.6.22.1-32 requires lm_sensors-2.10.4-1
fancontrol: Kernel kernel-2.6.22.1-32 requires lm_sensors-2.10.4-1
Status: CLOSED DUPLICATE of bug 248674
Product: Fedora
Classification: Fedora
Component: lm_sensors (Show other bugs)
6
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-09 16:00 EDT by Mace Moneta
Modified: 2015-03-04 20:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-10 07:56:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mace Moneta 2007-08-09 16:00:42 EDT
Description of problem:

After installing the new kernel (kernel-2.6.22.1-32.fc6), fancontrol no longer
worked.  Attempting to re-run pwmconfig failed (no devices found).  Upgrading to
the development version of lm_sensors (lm_sensors-2.10.4-1.fc8, no requisites
required) corrected the problem.  The fan control appears to have relocated to a
different portion /sys hierarchy.

Version-Release number of selected component (if applicable):

lm_sensors-2.10.1-1.fc6

How reproducible:

Always

Steps to Reproduce:
1. Install kernel 2.6.22.1-32
2. fancontrol fails
3. Upgrade lm_sensors to 2.10.4-1
4. Reconfigure with pwmconfig
5. fancontrol works
  
Actual results:

fancontrol fails

Expected results:

fancontrol works

Additional info:

New /etc/fancontrol:

INTERVAL=5
FCTEMPS=hwmon1/device/pwm2=hwmon1/device/temp2_input
FCFANS= hwmon1/device/pwm2=hwmon1/device/fan2_input
MINTEMP=hwmon1/device/pwm2=0
MAXTEMP=hwmon1/device/pwm2=60
MINSTART=hwmon1/device/pwm2=230
MINSTOP=hwmon1/device/pwm2=205

Prior /etc/fancontrol:

INTERVAL=5
FCTEMPS= 9191-0290/pwm2=9191-0290/temp2_input
FCFANS= 9191-0290/pwm2=9191-0290/fan2_input
MINTEMP= 9191-0290/pwm2=25
MAXTEMP= 9191-0290/pwm2=45
MINSTART= 9191-0290/pwm2=120
MINSTOP= 9191-0290/pwm2=85
Comment 1 Hans de Goede 2007-08-10 07:56:53 EDT
Known issue, its a dup of bug 248674


*** This bug has been marked as a duplicate of 248674 ***

Note You need to log in before you can comment on or make changes to this bug.