Bug 251577 - kernel 2.6.22.1-32 fails to mount root filesystem and fails to boot
kernel 2.6.22.1-32 fails to mount root filesystem and fails to boot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-09 16:51 EDT by David Rees
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.6.22.2-42.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-20 14:21:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
system1-mountfailed.png (11.86 KB, image/png)
2007-08-09 16:52 EDT, David Rees
no flags Details
system2-mountfailed.png (19.19 KB, image/png)
2007-08-09 16:53 EDT, David Rees
no flags Details

  None (edit)
Description David Rees 2007-08-09 16:51:42 EDT
After installing 2.6.22.1-32 on 2 different systems and rebooting them, they
both fail to boot with the same errors. Reverting to 2.6.20-1.2962 boots fine.

Each system uses different hardware. system1 uses a 3ware RAID card, system2
usees an aacraid card. Each is partitioned the same using labels. Changing grub
and fstab to use raw devices instead of labels doesn't change the behavior.

/dev/sda1 /boot
/dev/sda2 swap
/dev/sda3 /

Here is what the console reports on both machines (attached are screenshots from
each as well):

Trying to resume from LABAL=swap
Unable to access resume device (LABEL=swap)
Creating root device.
Mounting root filesystem.
mount: could not find filesystem '/dev/root'
Setting up other filesystems.
Setting up new root fs.
setuproot: moving /dev failed: No such file or directory
no fstab.sys, mounting internal defaults
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
Switching to new root and running init.
unmounting old /dev
unmounting old /proc
unmounting old /sys
switchroot: mount failed: No such file or directory
Kernel panic - not sycning: Attempted to kill init!
Comment 1 David Rees 2007-08-09 16:52:25 EDT
Created attachment 161021 [details]
system1-mountfailed.png

System 1. This has a 3ware IDE RAID controller.
Comment 2 David Rees 2007-08-09 16:53:10 EDT
Created attachment 161022 [details]
system2-mountfailed.png

System 2. This has an aacraid SCSI raid controller.
Comment 3 Chuck Ebbert 2007-08-09 18:18:45 EDT
Okay, this is probably due to the SCSI asyncrhonous scanning being enabled.
Fixed in CVS, new kernel is building.
Comment 4 David Rees 2007-08-09 19:36:28 EDT
It seems that F7 also has SCSI asynchronous scanning enabled (I just upgraded
one of those machines to F7) and it doesn't have any issues finding the root
devices and booting up. Is there some userspace script that needs fixing to
enable this feature reliably?

Perhaps that would be the better fix rather than disabling SCSI_SCAN_ASYNC which
can significantly reduce boot times on some systems.
Comment 5 Chuck Ebbert 2007-08-09 19:43:12 EDT
F7 has a new version of mkinitrd and I'm not so sure we want to require that.
Async scanning was off in the previous FC6 kernel anyway, so leaving it off
isn't a regression.
Comment 6 Chuck Ebbert 2007-08-10 17:25:44 EDT
Test kernel with async SCSI scan disabled is at:

http://people.redhat.com/cebbert/kernels/FC6/
Comment 7 David Rees 2007-08-10 20:03:51 EDT
Thanks, unfortunately I won't be able to test until Monday - all my home
machines are already on F7.
Comment 8 p thompson 2007-08-10 22:05:18 EDT
This kernel fixes my booting problem, which was with an aic7892: Ultra160 with a
number of luns and the same messages:
unmounting old /dev
unmounting old /proc
unmounting old /sys
switchroot: mount failed: No such file or directory
Kernel panic - not sycning: Attempted to kill init!
Comment 9 Radek Liboska 2007-08-13 08:25:16 EDT
same problem with Adaptec 29160N Ultra160 SCSI adapter;
kernel-2.6.22.2-39.fc6 is OK, thanks 
Comment 10 David Rees 2007-08-13 14:46:16 EDT
Can confirm that kernel-2.6.22.2-39.fc6 fixes the boot issue on the my system
which uses a 3ware RAID card.

Haven't tested my other system since it has 4GB+ ram and it is using a PAE
kernel right now, but I would expect it to work fine, too given the other
reports of success.
Comment 11 Joachim Frieben 2007-08-15 08:12:25 EDT
kernel-2.6.22.2-39.fc6 works fine again with my onboard AIC-7880
controller chip.
Comment 12 David Rees 2007-08-15 14:33:30 EDT
Looks like the updated kernel has hit updates-testing, I have successfully
booted my other FC6 machine with kernel-PAE-2.6.22.2-39.fc6 and the aacraid
driver without issue.
Comment 13 smcs 2007-08-19 14:13:25 EDT
This was fixed in 2.6.22.2-39 but seems to be broken again (same failure mode as
2.6.22.1-32) in 2.6.22.2-42.
Comment 14 Joachim Frieben 2007-08-20 08:15:03 EDT
(In reply to comment #13)
I cannot confirm this regression. Booting 2.6.22.2-42.fc6, all volumes
are found and mounted as expected.
Comment 15 Paul Edwards 2007-08-20 12:42:42 EDT
Same issue occuring under 2.6.22.2-42 with LSI Logic drivers (under vm).  
Booting into 2.6.18 lvm shows all groups, yet none are found when booting under 
default 2.6.22.2-42 (after yum update).
Comment 16 Chuck Ebbert 2007-08-20 14:19:51 EDT
(In reply to comment #13)
> This was fixed in 2.6.22.2-39 but seems to be broken again (same failure mode as
> 2.6.22.1-32) in 2.6.22.2-42.

This bug has been fixed, there may be a different one preventing boot though.
Open a new bug if the problem continues.
Comment 17 Chuck Ebbert 2007-08-20 14:21:42 EDT
(In reply to comment #15)
> Same issue occuring under 2.6.22.2-42 with LSI Logic drivers (under vm).  
> Booting into 2.6.18 lvm shows all groups, yet none are found when booting under 
> default 2.6.22.2-42 (after yum update).

Bugs in vm can be fixed by choosing a different controller emulation. This is
not a kernel bug -- the vm isn't properly emulating the controller.

Note You need to log in before you can comment on or make changes to this bug.