Bug 251594 - Driver for /etc/xen config files does not correctly handle virtual networks
Summary: Driver for /etc/xen config files does not correctly handle virtual networks
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt (Show other bugs)
(Show other bugs)
Version: 5.1
Hardware: All Linux
low
low
Target Milestone: ---
: ---
Assignee: Daniel Veillard
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-09 21:44 UTC by Daniel Berrange
Modified: 2009-12-14 21:22 UTC (History)
2 users (show)

Fixed In Version: RHEA-2007-0643
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 17:27:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Demo XML with networking (736 bytes, text/xml)
2007-08-09 21:44 UTC, Daniel Berrange
no flags Details
Fix handling of virtual networks (4.13 KB, patch)
2007-08-09 21:45 UTC, Daniel Berrange
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2007:0643 normal SHIPPED_LIVE libvirt enhancement update 2007-11-08 14:15:22 UTC

Description Daniel Berrange 2007-08-09 21:44:11 UTC
Description of problem:
When attempting to define a guest using a virtual network like

  <interface type='network'>
      <mac address='00:16:3e:60:36:ba'/>
      <source network='default'/>
  </interface>

The resulting config file is incorrect - missing the name of the bridge device
associated with the network. This is *very* serious bug because it means the
guest will be attached to the wrong network device.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  virsh define demo.xml  (see attached XML)
2.  grep vif /etc/xen/rhel5pv3
3.
  
Actual results:
vif = [ "mac=00:16:3e:60:36:ba" ]


Expected results:
vif = [ "mac=00:16:3e:60:36:ba,bridge=virbr0" ]

Additional info:

Comment 1 Daniel Berrange 2007-08-09 21:44:11 UTC
Created attachment 161028 [details]
Demo XML with networking

Comment 2 Daniel Berrange 2007-08-09 21:45:02 UTC
Created attachment 161030 [details]
Fix handling of virtual networks

Comment 4 Daniel Veillard 2007-08-13 21:05:26 UTC
Libvirt libvirt-0_2_3-6_el5 has been built with the fix in dist-5E-qu-candidate

Daniel

Comment 8 errata-xmlrpc 2007-11-07 17:27:11 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0643.html



Note You need to log in before you can comment on or make changes to this bug.