Bug 251596 - Logrotate problem using the size config without any time config (daily, etc.)
Logrotate problem using the size config without any time config (daily, etc.)
Status: CLOSED DUPLICATE of bug 247410
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: logrotate (Show other bugs)
i686 Linux
low Severity high
: ---
: ---
Assigned To: Tomas Smetana
Depends On:
  Show dependency treegraph
Reported: 2007-08-09 17:45 EDT by joel winteregg
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-08-13 03:48:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description joel winteregg 2007-08-09 17:45:52 EDT
Description of problem:
The "size" configuration statement of logrotate only works when a time config is
present ("daily", "weekly", etc..). So it seems the "size" config statement
behave like logrotate man page define its "minsize" config statement. I did many
testing and my log where only rotated when they were bigger than my size config
AND when a "daily" was configured.

Version-Release number of selected component (if applicable): 3.7.4-7

How reproducible:

- Logrotate configuration -
# keep 1 year of logs (if daily rotation)
rotate 365 

# no rotation on empty log files

# don't report an error on configurated log files which are missing

/path/to/my/dir/*.log {

Steps to Reproduce:
1. Remove the status file /var/lib/logrotate/status 
2. Launch logrotate with the given config

Actual results:
No logs are rotated

Expected results:
Logs > 100k should be rotated as gz file

Additional info:
If i add the "daily" config statement in the given config and then do what is
written in "Steps to Reproduce" and then if I change the OS date to simulate a
day later and launch logrotate again, it will rotate logs which are bigger than
100k !
Comment 1 Tomas Smetana 2007-08-13 03:48:32 EDT
This bug has the same cause as bug #247410. Marking as duplicate.

*** This bug has been marked as a duplicate of 247410 ***

Note You need to log in before you can comment on or make changes to this bug.