Bug 25162 - gcc 2.96-69 and 2.96-71 core dump while compiling CVS of csytalspace
gcc 2.96-69 and 2.96-71 core dump while compiling CVS of csytalspace
Status: CLOSED DUPLICATE of bug 23716
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-28 19:41 EST by jfm2
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-30 16:34:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jfm2 2001-01-28 19:41:13 EST
While compiling crytalspace CVS (25 Jan 2001 version) I get the following
message:

gcc -c -o out/LINUX/INTEL/optimize/camera.o libs/csengine/camera.cpp -Wall
-Wunused -W -mpentium -march=i586 -fno-exceptions -fno-rtti -O6
-fomit-frame-pointer -ffast-math -I. -I./apps -I./include -I./libs
-I./plugins -I./support
libs/csengine/camera.cpp: In method `void csCamera::LookAt (const 
csVector3 &, const csVector3 &)':
libs/csengine/camera.cpp:163: Internal compiler error in replace_reg, 
at reg-stack.c:830
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[1]: *** [out/LINUX/INTEL/optimize/camera.o] Erreur 1
make: *** [csengine] Erreur 2


This happens both  with the gcc from RedHat updates (2.96-69) and with the
one in Rawhide (2.96-71)
Comment 1 Jakub Jelinek 2001-01-30 16:34:06 EST
Can you please add -save-temps option and attach here camera.i
it generates?
Comment 2 Jakub Jelinek 2001-01-31 05:28:43 EST

*** This bug has been marked as a duplicate of 23716 ***

Note You need to log in before you can comment on or make changes to this bug.