Bug 251660 - ppc64 libstdc++ link issues
ppc64 libstdc++ link issues
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
ppc64 Linux
high Severity high
: ---
: ---
Assigned To: Roland McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-10 05:59 EDT by Denis Leroy
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-11 14:40:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Denis Leroy 2007-08-10 05:59:22 EDT
I'm having build problems on ppc64 with some C++ packages. The error is always:

/usr/lib/gcc/ppc64-redhat-linux/4.1.2/libstdc++.so: undefined reference to
`strtold_l@GLIBC_2.4'
Comment 2 Roland McGrath 2007-08-10 18:53:12 EDT
This should be fixed by glibc-2.6.90-8
Comment 3 Hans de Goede 2007-08-11 03:16:08 EDT
Notice this happens on plain ppc too, see:
http://koji.fedoraproject.org/koji/taskinfo?taskID=97049

(and yes that failure is caused by this bug)
Comment 4 Mamoru TASAKA 2007-08-11 05:58:03 EDT
Rebuild against -8 seems okay.

http://koji.fedoraproject.org/koji/taskinfo?taskID=97464
Comment 5 Hans de Goede 2007-08-11 06:43:12 EDT
Yes, and it works on ppc now too:
http://koji.fedoraproject.org/koji/taskinfo?taskID=97540
Comment 6 Denis Leroy 2007-08-11 14:40:47 EDT
Roland, thanks for the fix. Fixed my brasero build problem (except now I hit the
open() macro problem, but that one has a known fix).

Note You need to log in before you can comment on or make changes to this bug.