Bug 251694 - Y2K bug in contemporary kernel
Y2K bug in contemporary kernel
Status: CLOSED DUPLICATE of bug 250238
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-10 09:40 EDT by Steve Snyder
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-10 12:51:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Snyder 2007-08-10 09:40:10 EDT
Description of problem:

Date is shown with the year "107".

Version-Release number of selected component (if applicable):

kernel-2.6.22.1-41.fc7

How reproducible:

Haven't tried.

Steps to Reproduce:
1. Run dmesg to view system log entries.
2. Note date (see Additional Info below)
3.
  
Actual results:

String is logged as "Date: 07/09/107"

Expected results:

System log entry should be either "07/09/07" or "07/09/2007"

Additional info:

This is a snippet of system log as seen with dmesg.  Note the date:

Brought up 2 CPUs
sizeof(vma)=84 bytes
sizeof(page)=32 bytes
sizeof(inode)=336 bytes
sizeof(dentry)=132 bytes
sizeof(ext3inode)=488 bytes
sizeof(buffer_head)=56 bytes
sizeof(skbuff)=176 bytes
sizeof(task_struct)=1536 bytes
Time: 22:30:38  Date: 07/09/107
NET: Registered protocol family 16
ACPI: bus type pci registered
PCI: PCI BIOS revision 2.10 entry at 0xfb3a0, last bus=4
PCI: Using configuration type 1
Comment 1 Steve Snyder 2007-08-10 09:46:51 EDT
My BIOS (motherboard: Supermicro P4DC6+) dates from 2003 so I doubt that this is
a  Y2K bug in that code.  FYI.
Comment 2 Andre Robatino 2007-08-10 10:01:29 EDT
  I can confirm on a Dell Dimension B110 bought in 2006.

Brought up 1 CPUs
sizeof(vma)=84 bytes
sizeof(page)=32 bytes
sizeof(inode)=336 bytes
sizeof(dentry)=132 bytes
sizeof(ext3inode)=488 bytes
sizeof(buffer_head)=56 bytes
sizeof(skbuff)=176 bytes
sizeof(task_struct)=1536 bytes
Time: 12:32:08  Date: 07/10/107
NET: Registered protocol family 16
ACPI: bus type pci registered
PCI: PCI BIOS revision 2.10 entry at 0xfbbf0, last bus=1
PCI: Using configuration type 1
Comment 3 Chuck Ebbert 2007-08-10 12:51:29 EDT
Known bug in the pm-trace code; it's just cosmetic and the fix is easy, we just
haven't gotten to it yet.

*** This bug has been marked as a duplicate of 250238 ***

Note You need to log in before you can comment on or make changes to this bug.