Bug 251711 - Transaction check error trying to update pam package
Transaction check error trying to update pam package
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: distribution (Show other bugs)
1.0
All Linux
low Severity high
: ---
: ---
Assigned To: Luis Claudio R. Goncalves
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-10 11:55 EDT by Darren Hart
Modified: 2008-02-27 14:54 EST (History)
0 users

See Also:
Fixed In Version: rt partners repo
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-17 17:32:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darren Hart 2007-08-10 11:55:49 EDT
Transaction check error trying to update pam package to the following versions
via yum update:

 pam                     x86_64     0.99.6.2-3.26.el5  rhel5-rt          970 k 
 pam-devel               x86_64     0.99.6.2-3.26.el5  rhel5-rt          189 k 

...

Transaction Check Error:   file /usr/share/man/man5/namespace.conf.5.gz from
install of pam-0.99.6.2-3.26.el5 conflicts with file from package
pam-0.99.6.2-3.14.el5 
  file /usr/share/man/man8/pam_access.8.gz from install of pam-0.99.6.2-3.26.el5
conflicts with file from package pam-0.99.6.2-3.14.el5 
  file /usr/share/man/man8/pam_limits.8.gz from install of pam-0.99.6.2-3.26.el5
conflicts with file from package pam-0.99.6.2-3.14.el5 
  file /usr/share/man/man8/pam_namespace.8.gz from install of
pam-0.99.6.2-3.26.el5 conflicts with file from package pam-0.99.6.2-3.14.el5 
  file /usr/share/man/man8/pam_selinux.8.gz from install of
pam-0.99.6.2-3.26.el5 conflicts with file from package pam-0.99.6.2-3.14.el5 
  file /usr/share/man/man8/pam_succeed_if.8.gz from install of
pam-0.99.6.2-3.26.el5 conflicts with file from package pam-0.99.6.2-3.14.el5 
  file /usr/share/man/man8/pam_time.8.gz from install of pam-0.99.6.2-3.26.el5
conflicts with file from package pam-0.99.6.2-3.14.el5 

...

There appears to be some misconfiguration of the pam package itself?
Comment 1 Luis Claudio R. Goncalves 2007-08-10 15:15:50 EDT
I am addressing this issue right now.
Comment 2 Luis Claudio R. Goncalves 2007-08-10 18:41:04 EDT
Could you please check if it is working now? It has passed my tests and 'yum
install rt-setup' worked fine.
Comment 3 Darren Hart 2007-08-13 13:37:43 EDT
Seems to be working - although I'm not sure what the public key at the end of
the output is all about.

# yum install rt-setup

...

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 rt-setup                x86_64     1.0-1.el5rt      rhel5-rt          2.9 k
Updating for dependencies:
 pam                     x86_64     0.99.6.2-3.26.el5  rhel5-rt          970 k

Transaction Summary
=============================================================================
Install      1 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total download size: 973 k
Is this ok [y/N]: y
Downloading Packages:
(1/2): pam-0.99.6.2-3.26. 100% |=========================| 970 kB    00:02     
(2/2): rt-setup-1.0-1.el5 100% |=========================| 2.9 kB    00:00     
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 37017186


Public key for pam-0.99.6.2-3.26.el5.x86_64.rpm is not installed
Comment 4 Luis Claudio R. Goncalves 2007-08-14 10:45:37 EDT
First of all, to fix this problem (you just have to run this command once):

    rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release

This way you are importing the RHEL 5 master key to rpm. That's the key used to
verify rpm packages signature, alerting you when they were not signed by Red Hat.

The point here is that this key is not imported during system instalation but at
the first yum invocation pointing to a RHEL 5 repository this key will be
automatically imported. But as you can see in rhel5-rt.repo (parameter gpgkey)
we refer to this key and another key, specific for the rt repository - which
gets automatically imported.

I am in contact with our engineering team to check whether we can force yum to
import both keys simultaneously or not.
Comment 5 Luis Claudio R. Goncalves 2007-08-15 17:49:43 EDT
The rpm signature problem is solved but in the process the pam arch conflict was
brought back.

I am discussing with engineering a solution other than the 'yum upgrade pam;
youm install rt-setup' threy proposed.
Comment 6 Luis Claudio R. Goncalves 2007-08-17 17:32:00 EDT
After lots of tests and discussions we agreed that the best procedure - that
will be documented in th wiki, is:

    yum update pam
    yum install rt-setup"

The first command updates both versions of pam and the second one installs
rt-setup and its requirements.

I believe this closes the bug but, please, feel free to reopen it.

Note You need to log in before you can comment on or make changes to this bug.