Bug 251729 - Kernels post 2.6.21-1.3228.fc7 do not display disks hanging of 3ware Inc 9xxx-series SATA-RAID devices
Kernels post 2.6.21-1.3228.fc7 do not display disks hanging of 3ware Inc 9xxx...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-10 14:28 EDT by Matt Darcy
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.22.5-76.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 18:00:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Darcy 2007-08-10 14:28:05 EDT
Description of problem:
using Fedora 7 x86_64 I have s 3ware Sata 8 port 9 series disk controller with 
8 disks attatched in a raid 5 device. Any kernel post 2.6.21-1.3228 boots fine, 
shows the device but does not show any disks hanging off it. The raid does not 
start due to lack of disks. booting kernel 2.6.21-1.3228 or earlier resolves 
this issue.

Version-Release number of selected component (if applicable):
Kernel Post 2.6.21-1.3228
How reproducible:
every time.

Steps to Reproduce:
1. Install Fedora 7 x86_64 on system with Sata 3ware 9 series controller
2. Configure disks off controller
3. update to kernel post 2.6.32-1.3228
4. check for disks.
  
Actual results:
no disks found, raid dead

Expected results:
8 disks found, raid started


Additional info:
I had this problem on fedora 7 x86_64 post 2.6.21-1.3228 with an Intel chipset 
Sata controller too. somewhere after the first release AFTER 2.6.21-1.2338 it 
got fixed. Currently working on 2.6.22.1-41.fc7 if you try 2.6.21-1.33 I 
believe this will fail on the intel chipset too though. 

This is not working on the 3ware controller at all.
Comment 1 Jarod Wilson 2007-08-10 15:06:59 EDT
Hrm... I'm running 2.6.22.1-41.fc7 on my own x86_64 system with a 3ware 9500S
8-port controller (PCI-X) with zero issues... Exactly what model do you have?

$ uname -a
Linux apollo.wilsonet.com 2.6.22.1-41.fc7 #1 SMP Fri Jul 27 18:21:43 EDT 2007
x86_64 x86_64 x86_64 GNU/Linux

$ /sbin/lsmod |grep 3w
3w_9xxx                43077  2 
scsi_mod              168697  5 sr_mod,sg,3w_9xxx,libata,sd_mod

---log output---
Aug  2 22:25:06 apollo kernel: 3ware 9000 Storage Controller device driver for
Linux v2.26.02.008.
Aug  2 22:25:06 apollo kernel: scsi4 : 3ware 9000 Storage Controller
Aug  2 22:25:06 apollo kernel: 3w-9xxx: scsi4: Found a 3ware 9000 Storage
Controller at 0xf2100000, IRQ: 29.
Aug  2 22:25:06 apollo kernel: 3w-9xxx: scsi4: Firmware FE9X 2.08.00.006, BIOS
BE9X 2.03.01.052, Ports: 8.
Aug  2 22:25:06 apollo kernel: scsi 4:0:0:0: Direct-Access     AMCC     9500S-8
   DISK  2.08 PQ: 0 ANSI: 3
Aug  2 22:25:06 apollo kernel: sd 4:0:0:0: [sde] 2929557504 512-byte hardware
sectors (1499933 MB)
Aug  2 22:25:06 apollo kernel: sd 4:0:0:0: [sde] Write Protect is off
Aug  2 22:25:06 apollo kernel: sd 4:0:0:0: [sde] Write cache: enabled, read
cache: disabled, doesn't support DPO or FUA
Aug  2 22:25:06 apollo kernel: sd 4:0:0:0: [sde] 2929557504 512-byte hardware
sectors (1499933 MB)
Aug  2 22:25:06 apollo kernel: sd 4:0:0:0: [sde] Write Protect is off
Aug  2 22:25:06 apollo kernel: sd 4:0:0:0: [sde] Write cache: enabled, read
cache: disabled, doesn't support DPO or FUA
Aug  2 22:25:06 apollo kernel:  sde: sde1 sde2
Aug  2 22:25:06 apollo kernel: sd 4:0:0:0: [sde] Attached SCSI disk
Comment 2 Jarod Wilson 2007-08-10 15:09:23 EDT
I'd also be curious to know your firmware revision. Perhaps newer drivers in
recent kernels require newer firmware...
Comment 3 Matt Darcy 2007-08-14 06:23:24 EDT
I will confirm the exact model later when I take the side pannel off the 
machine.

Your firmware comment is very valid. This will not be an easy task to update as 
the firmware tools for the 3ware cards appear to require a dos boot disk and 
dos tools which I don't have to hand, nor do I have a floppy drive on this 
machine, so I'll have to improvise.

For the information for this log, a working system status/config looks like this

Linux berger.projecthugo.co.uk 2.6.21-1.3228.fc7 #1 SMP Tue Jun 12 14:56:37 EDT 
2007 x86_64 x86_64 x86_64 GNU/Linux

[root@berger ~]# lsmod | grep 3w
3w_9xxx                43077  8
scsi_mod              165241  5 sr_mod,sg,3w_9xxx,libata,sd_mod

md6 : active raid5 sdc1[0] sdj1[7](S) sdi1[6] sdh1[5] sdg1[4] sdf1[3] sde1[2] 
sdd1[1]
      1464741120 blocks level 5, 128k chunk, algorithm 2 [7/7] [UUUUUUU]

[root@berger ~]# fdisk -l /dev/sde

Disk /dev/sde: 249.9 GB, 249988907008 bytes
255 heads, 63 sectors/track, 30392 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sde1               1       30392   244123708+  fd  Linux raid autodetect
[root@berger ~]# fdisk -l /dev/sdf

Disk /dev/sdf: 249.9 GB, 249988907008 bytes
255 heads, 63 sectors/track, 30392 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdf1               1       30392   244123708+  fd  Linux raid autodetect


----------------------------------------------------------------------------
one thing of interest is I am seeing this error a lot in the output from dmesg

ATA: abnormal status 0x8 on port 0x00000000000101f7
ATA: abnormal status 0x8 on port 0x00000000000101f7
ata3.00: configured for PIO0
ata3: EH complete
sr 3:0:0:0: ioctl_internal_command return code = 8000002
   : Current [descriptor]: sense key: Aborted Command
    Additional sense: No additional sense information
ata3.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata3.00: cmd a0/00:00:00:00:20/00:00:00:00:00/a0 tag 0 cdb 0x0 data 0
         res 40/00:03:00:00:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
ata3: soft resetting port
ATA: abnormal status 0x8 on port 0x00000000000101f7
ATA: abnormal status 0x8 on port 0x00000000000101f7
ata3.00: configured for PIO0
ata3: EH complete
ata3.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata3.00: cmd a0/00:00:00:00:20/00:00:00:00:00/a0 tag 0 cdb 0x0 data 0
         res 40/00:03:00:00:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
ata3: soft resetting port
ATA: abnormal status 0x8 on port 0x00000000000101f7
ATA: abnormal status 0x8 on port 0x00000000000101f7
ata3.00: configured for PIO0
ata3: EH complete


From a later kernel ......

----------------------------------------------------------------------
Linux berger.projecthugo.co.uk 2.6.22.1-41.fc7 #1 SMP Fri Jul 27 18:21:43 EDT 
2007 x86_64 x86_64 x86_64 GNU/Linux

[root@berger ~]# lsmod | grep 3w
3w_9xxx                43077  0
scsi_mod              168697  5 sr_mod,sg,3w_9xxx,libata,sd_mod

[root@berger ~]# fdisk -l /dev/sde
[root@berger ~]# fdisk -l /dev/sdf

however this time in dmesg I do not see the port errors on the card.

I will try to get the exact card model later.

The output of a verbose lspci looks like this for the card.

00:0a.0 RAID bus controller: 3ware Inc 9xxx-series SATA-RAID
        Subsystem: 3ware Inc 9xxx-series SATA-RAID
        Control: I/O+ Mem+ BusMaster- SpecCycle+ MemWINV+ VGASnoop- ParErr- 
Stepping- SERR+ FastB2B-
        Status: Cap+ 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- 
<TAbort- <MAbort- >SERR- <PERR-
        Interrupt: pin A routed to IRQ 18
        Region 0: I/O ports at c800 [size=256]
        Region 1: Memory at dffff400 (64-bit, non-prefetchable) [size=256]
        Region 3: Memory at d1000000 (64-bit, prefetchable) [size=8M]
        Expansion ROM at dffe0000 [disabled] [size=64K]
        Capabilities: [48] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME
(D0+,D1+,D2+,D3hot+,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

Comment 4 Matt Darcy 2007-08-16 08:17:57 EDT
tw_cli from the 3ware site (card/controller command line tools) shows the card 
as 

Ctl   Model        Ports   Drives   Units   NotOpt   RRate   VRate   BBU
------------------------------------------------------------------------
c2    9500S-8      8       8        8       0        4       4       -



so a 9500-S card.

Where doesn't appear to be a method of viewing the current firmware using the 
tw_cli tools, I've just downloaded the 9.3.0.8 firmware and will flash ASAP.

I'd be very interested in someone else with the 9500-S card reporting how their 
card words with the post 2.6.21-1.3228 kernels.
Comment 5 Matt Darcy 2007-08-16 08:19:39 EDT
I should add that I notice that James is also running the same card and it is 
working. James what firmware version are you running ?
Comment 6 Matt Darcy 2007-08-16 08:41:40 EDT
Additional update - the tw_cli tools are actually really good. 

For reference to this thread the full documentation on the tools can be found 
http://www.3ware.com/support/UserDocs/3ware9500SCLIGuide.pdf

I'm currently running Firmware Version = FE9X 2.04.00.005 so reasonable 
different the 9.3.0.8 firmware I've just downloaded (that version seems VERY 
different)

I'd be very interested in knowing the versions currently running on a working 
card.



Comment 7 Matt Darcy 2007-08-16 12:43:21 EDT
Additional information for reference with this bug

Current 9500s card information (bios/firmware/driver/etc) can be found at 
http://www.3ware.com/kb/article.aspx?id=11935

The current information at time of writing this bug is.

 9.2.1.1 Escalade Code 9.2.1.1 - Released August 2005 
BIOS (3BM) BG9X - 2.03.01.052 (NEW)
Firmware - FGxx 2.08.00.005(NEW)
A/P chip 3.2/1.5
Models supported 9500S
BBU Firmware - 1.04.00.022
Linux driver 2.4 kernel 2.24.03.019fw (NEW)
Linux driver 2.6 kernel 2.26.03.019fw (NEW)
(note:  all Linux and FreeBSD bundled with older fw 2.08.00.003)
Windows driver 32-bit 2.06.03.040 (NEW) (2K/XP/2K3)
Windows driver 64-bit 2.06.03.042 (NEW) (XP/2K3)
FreeBSD v5.4 only driver 3.50.01.003 (NEW)
Linux and Win 3DM2 - 2.03.00.028 (NEW)
Windows and Linux CLI - 2.00.02.009 (NEW)
Redhat releases WS3 Update 3 (2.4 kernel) for Intel x86, 32-bit Athlon and 64-
bit Opteron/EM64T
SuSE releases 9.2 Pro (2.6 kernel) for Intel x86, 32-bit Athlon, and 64-bit 
Opteron/EM64T
Windows releases 2003, XP w/SP1, 2000 w/SP3 for Intel x86, 32-bit Athlon and 64-
bit Opteron/EM64T
FreeBSD Releases 5.4 only

 

Looking at my cards revisions:

Bios Version = BE9X 2.03.01.047
Firmware Version = FE9X 2.04.00.005
Driver Version = 2.26.02.008

I'm quite a way out.

I'll update mine to these versions.

Jarod, or anyone with a working config, I'd be interested in your versions for 
reference.
Comment 8 Jarod Wilson 2007-08-16 14:19:37 EDT
The firmware version is reported in dmesg after the card is brought up:

3ware 9000 Storage Controller device driver for Linux v2.26.02.008.
ACPI: PCI Interrupt 0000:04:01.0[A] -> GSI 29 (level, low) -> IRQ 29
scsi4 : 3ware 9000 Storage Controller
3w-9xxx: scsi4: Found a 3ware 9000 Storage Controller at 0xf2100000, IRQ: 29.
3w-9xxx: scsi4: Firmware FE9X 2.08.00.006, BIOS BE9X 2.03.01.052, Ports: 8.

That's from booting kernel 2.6.22.1-41.fc7. Yeah, your bios and firmware both
appear to be a few revisions older. I think I last flashed my card roughly a
year ago...
Comment 9 Matt Darcy 2007-08-17 09:10:48 EDT
as a side note, am I right in assmuming your use the driver from the kernel 
rather than the 3ware downloaded one.

I am using the driver from the kernel, but reading the information on the 3ware 
site they suggest that their driver (although its old and still references lots 
of 2.4 kernels) is "better".

I'm sticking with the kernel driver, but thought it worth asking this of you.
Comment 10 Jarod Wilson 2007-08-17 09:58:15 EDT
I'm just using the in-kernel driver myself, always have. The upstream maintainer
for the in-kernel 3ware driver is 3ware themselves, if I recall correctly, so
unless they have brand new drivers available on their site that haven't been
merged into the kernel yet, you end up with the same thing.
Comment 11 Matt Darcy 2007-08-20 14:14:48 EDT
we may have a problem.

Updated to latest stable firmware from 3ware. 
http://www.3ware.com/download/Escalade9500SSeries/9.3.0.8/9.3.0.8-9500s-
Upgrade.zip

used a dos boot disk - no problems, install upgraded fine.

Booted from the 2.6.22.1-41.fc7 kernel. No disks, as before. Used the firmware 
tools as before to verify that the card had been flashed ok, "no 3ware devices 
present, please make sure the drivers are loaded". Double checked and lsmod 
shows the same drivers as before loaded. 

Booted back into 2.6.21-1.3228.fc7 and disks are there, and the card is working.
and the tw_cli tools are working again

/c2 Firmware Version = FE9X 2.08.00.009

I'm now using the latest stable version and stuck on the 2.6.21-1.3228.fc7 
kernel. I note this update is a few revisions past your own jarod.

Any comment / suggestions ?

I don't really want to start using unstable firmware patches.




Comment 12 Matt Darcy 2007-08-24 08:46:22 EDT
I have tested 2 firmware revisions down takig me to 2.08.00.07 which is as 
close as I can get to your confirmed working version and still have the same 
problem of not being able to see any disks post kernel 2.6.21-1.3228
Comment 13 Chuck Ebbert 2007-08-24 10:27:53 EDT
(In reply to comment #12)
> I have tested 2 firmware revisions down takig me to 2.08.00.07 which is as 
> close as I can get to your confirmed working version and still have the same 
> problem of not being able to see any disks post kernel 2.6.21-1.3228
> 

Is it trying to use MSI interrupts? What does /proc/interrupts say about the
controller? And try adding "pci=nomsi" to the kernel command line.

Comment 14 Matt Darcy 2007-08-24 11:01:35 EDT
I've never heard of the phrase MSI interrupts, so I can't comment on that.

From a working kernel, /proc/interrupts shows this reference to the card

 18:       1409          0   IO-APIC-fasteoi   3w-9xxx

Botting with "pci=nomsi" the 2.6.22.1-41.fc7 kernel shows nothing in reference 
to the 3ware card    
 CPU0       CPU1
  0:     122776          0   IO-APIC-edge      timer
  1:          8          0   IO-APIC-edge      i8042
  6:          6          0   IO-APIC-edge      floppy
  8:          0          0   IO-APIC-edge      rtc0
  9:          0          0   IO-APIC-fasteoi   acpi
 12:          4          0   IO-APIC-edge      i8042
 14:         62         74   IO-APIC-edge      libata
 15:          0          0   IO-APIC-edge      libata
 16:      11472          0   IO-APIC-fasteoi   cx88[1], cx88[1]
 17:        346         24   IO-APIC-fasteoi   HDA Intel, eth1
 19:       2726       8761   IO-APIC-fasteoi   cx88[0], cx88[0]
 20:          0          0   IO-APIC-fasteoi   uhci_hcd:usb1
 21:       9652       1056   IO-APIC-fasteoi   uhci_hcd:usb3, ehci_hcd:usb5, 
sata_via
 22:          0          0   IO-APIC-fasteoi   uhci_hcd:usb2
 23:        203        126   IO-APIC-fasteoi   uhci_hcd:usb4, eth0
NMI:          0          0
LOC:     122674     122629
ERR:          0

yet the modules are loaded

scsi_mod              168697  5 sr_mod,sg,3w_9xxx,libata,sd_mod

No disks can be seen and again, the 3ware tools don't show any card once booted 
into a later kernel release.






Comment 15 Matt Darcy 2007-08-24 11:59:08 EDT
The 2.6.22.4-65.fc7 kernel got released about 2 minutes after my last post so 
I've just tried it with 2.6.22.4-65.fc7 and I have the same problem, same 
interupts output also.

Almost as if the card isn't seen 
Comment 16 Matt Darcy 2007-08-24 12:05:25 EDT
I've just walked through the output of dmesg from a failing kernel line by 
line, and cannot see any reference to the 3com card. 

From the OS point of view the card cannot be seen, which explains why the 3ware 
tools can't probe is and no disks can be seen and the lack of interupts.

however 
lspci still shows it as seen 
00:0a.0 RAID bus controller: 3ware Inc 9xxx-series SATA-RAID

and the kernel is still loading modules for it

3w_9xxx                43077  0
scsi_mod              168825  5 sr_mod,sg,3w_9xxx,libata,sd_mod


Comment 17 Matt Darcy 2007-08-24 12:07:10 EDT
correction, in the latest kernel I get this error within dmesg. I was not 
getting that in the earlier kernels.

3ware 9000 Storage Controller device driver for Linux v2.26.02.008.
3w-9xxx: ERROR: (0x06:0x0023): Failed to set dma mask.
3w-9xxx: probe of 0000:00:0a.0 failed with error -5


Comment 18 Matt Darcy 2007-08-24 12:10:49 EDT
This appears to be a known problem and patched in a recent kernel update. 
Although the fedora kernel seems to have gone beyond this kernel version I'm 
checking to see if this patch is in place in the current kernels.
Comment 19 Matt Darcy 2007-08-24 12:16:21 EDT
sorry, I forgot to post the link

http://www.mail-archive.com/linux-scsi@vger.kernel.org/msg08545.html

I don't think this patch is in the current fedora kernel as the version number 
of the driver is still at v2.26.02.008 and this patch changes it to v2.26.02.010
Comment 20 Chuck Ebbert 2007-08-24 12:42:23 EDT
Okay, I extracted just the DMA mask change for Fedora. This puts the driver at
v2.26.02.009.
Comment 21 Matt Darcy 2007-08-24 13:47:37 EDT
great, although I'm curious as to why Jarod, using the same card as me is not 
having this problem, and why this problem only appears on the post 2.6.21-3228 
kernels.

How will this change be filtered down ?
Comment 22 Chuck Ebbert 2007-08-24 13:58:50 EDT
(In reply to comment #21)
> great, although I'm curious as to why Jarod, using the same card as me is not 
> having this problem, and why this problem only appears on the post 2.6.21-3228 
> kernels.
> 

His machine probably supports 64-bit DMA. Yours may not, or at least the updated
kernel may think it doesn't. What chipset is it? (Just post output of 'lspci'.)

> How will this change be filtered down ?

It will be in the next kernel release.
Comment 23 Jarod Wilson 2007-08-24 14:07:24 EDT
Chuck beat me to the punch... Apologies for my lack of replies this week, been a
bit buried...

But yeah, what Chuck said. I'm guessing 64-bit dma is failing on your system for
some reason, but isn't on mine, thus I'm not getting hit by the 32-bit fallback
bug that patch addresses. Not sure if its directly relevant, but my card is in a
64-bit PCI slot, and I'm pretty certain it fully supports 64-bit dma (its on a
relatively new server-class dual opteron motherboard).
Comment 24 Matt Darcy 2007-08-29 09:16:16 EDT
I would have expected my motherboard to support a 64bit dma to as its a very 
new home class system for a home server solution. 

Will there be an update/test kernel released shortly with the updated driver 
patch ?

I'm also quite surprised this is not in the fedora 2.6.22 kernel base as the 
patch I submitted the url for appears to be in the 2.6.21 kernel.
Comment 25 Jarod Wilson 2007-08-29 09:30:26 EDT
The 3ware patch should be in the latest kernels built in koji:

http://koji.fedoraproject.org/packages/kernel/2.6.22.5/71.fc7/

That same kernel has also been pushed into the fedora 7 updates-testing repo.

As for 64-bit dma... home server class strikes me as slightly more budget
conscious than enterprise server class, so the mfg may have skimped. Could also
just be that a future bios update will fix it, who knows for sure. Does the
board actually have a 64-bit pci-x slot that the card is sitting in?
Comment 26 Matt Darcy 2007-08-29 09:38:02 EDT
I'll try to grab the new kernel tonight from the testing repo to test.

This board isn't exactly a budget board but I agree that home solutions skip 
features over an enterprise solution. I'll have to check if it is in the 64bit 
PCI slot, but I'll only be able to check later.

thanks for the efforts on this.
Comment 27 Matt Darcy 2007-08-29 09:58:26 EDT
Just tested the 2.6.22.5-71.fc7

In terms of the SATA cards behaviour with my firmware, the card can now be 
seen, the disks are now accessable, and I can use functions such as read cache 
without issue, I've also lost the port warning errors in the syslog so the card 
looks to be behaving normally. My machines other functions seem fine at a 
glance but I've only focused on checking the sata cards behaviour
Comment 28 Matt Darcy 2007-08-31 07:43:37 EDT
I've now been running with this kernel for a few days. 

no issues, everything seems to be working ok.

What is the Fedora process to get this officially tested and submitted for 
stable deployment to the main repo's
Comment 29 Matt Darcy 2007-09-07 09:00:33 EDT
Turn around on debugging and resolving this issue has been fantastic, can I 
please get a status update on how far along the test procedure a kernel / this 
kernel with the 32bit DMA patch applied is.

Thanks.
Comment 30 Chuck Ebbert 2007-09-07 09:23:10 EDT
The kernel is in the updates-testing repository. From the fedora-updates-testing
mailing list:

--------------------------------------------------------------------------------
Fedora Test Update Notification
FEDORA-2007-1932
2007-09-04 15:02:42.604287
--------------------------------------------------------------------------------

Name        : kernel
Product     : Fedora 7
Version     : 2.6.22.5
Release     : 76.fc7
Summary     : The Linux kernel (the core of the Linux operating system)
Description :
The kernel package contains the Linux kernel (vmlinuz), the core of any
Linux operating system.  The kernel handles the basic functions
of the operating system:  memory allocation, process allocation, device
input and output, etc.

--------------------------------------------------------------------------------
Update Information:

Update to Linux kernel 2.6.22.5:
http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.22.5

Update to Linux kernel 2.6.22.6-rc1.

Update wireless drivers.
Allow b43 wireless driver to use old microcode format.
Add at76_usb wireless driver.
CFS scheduler v20.5+.
V4L/DVB: fix airstar hd5000 tuner.
Fix 3ware 9000 controller DMA fallback (#251729)
Fix PPC Pegasos PS/2 port detection.
Add new interrupt handler fixes from upstream.
ALSA: fix ad1988 spdif output (#253777).
ALSA: mutiple stac92xx codec fixes.
libata: fix pata_via driver on PPC Pegasos platform (#247602).
Enable the i82365 ISA PCMCIA driver.
Fix wrong date/time reported in boot messages (#250238).
Fix IRDA on some HP notebooks (#260481).
Workaround for atl1 network adapter on 64-bit systems (#249511).


Note You need to log in before you can comment on or make changes to this bug.