Bug 251740 - RFE: consistent naming of images
RFE: consistent naming of images
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-10 15:18 EDT by Till Maas
Modified: 2017-02-21 11:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-21 11:11:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Till Maas 2007-08-10 15:18:35 EDT
Description of problem:

Currently Live and Installation media use a completely different naming schema:

F-7.90-i386-DVD.iso 
Fedora-8-Test-1-Live-i686.iso

How about:
Fedora-7.90-i386-DVD.iso
Fedora-7.90-i686-Live.iso

or

Fedora-8-Test-1-i386-DVD.iso 
Fedora-8-Test-1-i686-Live.iso

Or in general:
Fedora-$COLLECTION_VER-$ARCH-$TYPE.iso
Comment 1 Jon Stanley 2008-04-23 16:30:26 EDT
Adding FutureFeature keyword to RFE's.
Comment 2 John Poelstra 2008-07-03 19:40:02 EDT
triaged
Comment 3 Jesse Keating 2008-12-02 00:35:45 EST
What makes this difficult is that livecd-tools currently uses the iso label as the iso filename, and there is an upper limit to the number of chars.  When dealing with the Education-Math spin, you rapidly run out of chars to use for other such things.  We probably need to come up with a way to define the iso label differently from the iso filename.
Comment 4 Till Maas 2008-12-03 09:42:24 EST
(In reply to comment #3)
> What makes this difficult is that livecd-tools currently uses the iso label as
> the iso filename, and there is an upper limit to the number of chars.  When
> dealing with the Education-Math spin, you rapidly run out of chars to use for
> other such things.  We probably need to come up with a way to define the iso
> label differently from the iso filename.

According to man genisomage the primary volume descriptor (option: -V) can take up to 32 characters, which would be enough for e.g.
Fedora-10-x86_64-Live-KDE-Snap1

Therefore at least all primary releases should fit except for the preview release,  but there "PR" was already used instead of Preview for some live images. If this is used, then everything would match.

Also in my initial comment, a original live image name was actually longer than the used non live image name.
Comment 5 Jesse Keating 2008-12-03 11:45:38 EST
That doesn't work for say the Education-Math spin, or the Developer spin, or BrOffice spin, or any spin that doesn't use a TLA.
Comment 6 Till Maas 2008-12-03 15:32:36 EST
(In reply to comment #5)
> That doesn't work for say the Education-Math spin, or the Developer spin, or
> BrOffice spin, or any spin that doesn't use a TLA.

This is true, but this is not a reason to use a consitent naming for the spins, where it is possible. Even if there is a different scheme for F12 than F11, because then livecd-tools allow to user the same naming scheme for all spins, it is still an improvement over the current situation. IIRC the naming scheme even changed for the different unstable releases of Fedora 10.
Comment 7 Jesse Keating 2008-12-03 16:59:59 EST
That's correct, I've been casting about trying to find a single scheme that will work for all, and I'm somewhat failing at it.  Mostly nobody is giving any feedback.  I'm leaving this open /because/ I'm trying to find a good solution.
Comment 8 Dennis Gilmore 2017-02-21 11:11:45 EST
I think we now have this all in place. I am closing the bug as fixed.

Note You need to log in before you can comment on or make changes to this bug.