Bug 251757 - anacron init scripts out to lunch (with bad installation as one of results)
anacron init scripts out to lunch (with bad installation as one of results)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anacron (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
: 252455 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-10 17:34 EDT by Michal Jaegermann
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 06:46:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2007-08-10 17:34:13 EDT
Description of problem:

After an update to anacron-2.3-49.fc8 we have the following:

# service anacron stop
Stopping anacron: Usage: killproc [-p pidfile] [ -d delay] {program} [-signal]
                                                           [FAILED]

Hm, ok. Lets try

# service anacron status
cron.daily is stopped

but 'pgrep -l -f  anacron' shows '4075 anacron -s'.

OTOH we have this:
# service anacron condrestart
Usage: /etc/init.d/anacron {start|stop|restart|status}

One of problems with the above is that 'rpm -q --scripts anacron'
prints:
.....
postuninstall scriptlet (using /bin/sh):
if [ "$1" -ge "1" ]; then
        service anacron condrestart >/dev/null 2>&1
fi

so this fails with a status 3 and after an update we are stuck
with double packages:
anacron-2.3-47.fc7
anacron-2.3-49.fc8
which have to be cleaned manually.  Even if 'condrestart' would
be present the the above likely needs '... || :' to be on a safe side.

Version-Release number of selected component (if applicable):
anacron-2.3-49.fc8

How reproducible:
always
Comment 1 Marcela Mašláňová 2007-08-13 04:47:53 EDT
Thanks for report, I change spec file and init script in anacron-2.3-50.fc7.
Comment 2 Marcela Mašláňová 2007-08-16 03:02:57 EDT
*** Bug 252455 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.