Bug 251840 - dependency problem
dependency problem
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-12 05:32 EDT by mail@romal.de
Modified: 2014-01-21 17:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-21 13:28:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mail@romal.de 2007-08-12 05:32:19 EDT
yum does not like glibc-updated pulled via dependencies. Updating manually works.

[root@beowulf ~]# yum update --skip-broken 
Loading "skip-broken" plugin
Setting up Update Process
Resolving Dependencies
**** Checking packages for dependency problems
**** Checking for dep problems  : python-debuginfo - 2.5.1-6.fc8.x86_64 
--> Running transaction check
---> Package python-debuginfo.x86_64 0:2.5.1-6.fc8 set to be updated
****   OK : python-debuginfo.x86_64 0-2.5.1-6.fc8 - u
**** Checking for dep problems  : ghostscript-fonts - 5.50-17.fc8.noarch 
--> Running transaction check
--> Processing Dependency: ghostscript-fonts for package: ghostscript
--> Processing Dependency: ghostscript-fonts for package: libgnomeprint22
--> Finished Dependency Resolution
****   Failed 
****     Unresolveable requirement ghostscript-fonts for ghostscript 
****     Unresolveable requirement ghostscript-fonts for libgnomeprint22 
**** Checking for dep problems  : xorg-x11-xdm - 1:1.1.5-1.fc8.x86_64 
--> Running transaction check
---> Package xorg-x11-xdm.x86_64 1:1.1.5-1.fc8 set to be updated
****   OK : xorg-x11-xdm.x86_64 1-1.1.5-1.fc8 - u
**** Checking for dep problems  : python-debuginfo - 2.5.1-4.fc8.x86_64 
--> Running transaction check
****   OK : python-debuginfo.x86_64 0-2.5.1-4.fc8 - None
**** Checking for dep problems  : koan - 0.4.0-2.fc7.noarch 
--> Running transaction check
****   OK : koan.noarch 0-0.4.0-2.fc7 - None
**** Checking for dep problems  : glibc - 2.6.90-8.x86_64 
--> Running transaction check
---> Package glibc.x86_64 0:2.6.90-8 set to be updated
--> Processing Dependency: glibc-common = 2.6.90-8 for package: glibc
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package glibc.x86_64 0:2.6.90-8 set to be updated
---> Package glibc-common.x86_64 0:2.6.90-8 set to be updated
--> Processing Dependency: glibc-common = 2.6.90-6 for package: glibc
Error: No Package Matching glibc.i686
[root@beowulf ~]# yum upgrade glibc
Loading "skip-broken" plugin
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package glibc.x86_64 0:2.6.90-8 set to be updated
---> Package glibc.i686 0:2.6.90-8 set to be updated
--> Processing Dependency: glibc-common = 2.6.90-8 for package: glibc
--> Processing Dependency: glibc = 2.6.90-6 for package: glibc-headers
--> Processing Dependency: glibc = 2.6.90-6 for package: glibc-devel
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package glibc-devel.x86_64 0:2.6.90-8 set to be updated
---> Package glibc-headers.x86_64 0:2.6.90-8 set to be updated
---> Package glibc-common.x86_64 0:2.6.90-8 set to be updated
---> Package glibc.x86_64 0:2.6.90-8 set to be updated
---> Package glibc.i686 0:2.6.90-8 set to be updated

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 glibc                   x86_64     2.6.90-8         development       4.6 M
 glibc                   i686       2.6.90-8         development       5.1 M
Updating for dependencies:
 glibc-common            x86_64     2.6.90-8         development        18 M
 glibc-devel             x86_64     2.6.90-8         development       2.4 M
 glibc-headers           x86_64     2.6.90-8         development       591 k

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       5 Package(s)         
Remove       0 Package(s)         

Total download size: 31 M
Is this ok [y/N]:
Comment 1 Jeremy Katz 2007-08-21 13:28:45 EDT
Should be fixed for yum 3.2.3

Note You need to log in before you can comment on or make changes to this bug.