This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 251889 - LUKS encripted USB disk won't automatically mount with last kernel
LUKS encripted USB disk won't automatically mount with last kernel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-13 03:52 EDT by Mario Pascucci
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-13 17:30:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mario Pascucci 2007-08-13 03:52:16 EDT
Description of problem:
Problem is similar to bug reported here for Fedora Core 6:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=209590
but there are some differencies:
- Gnome pops up a panel to request a password when you insert disk, but has no
effect: even if you put a wrong password the panel don't shows up again.
- no device shows up in /dev/mapper
- module dm_crypt is not loaded
- if you open a root shell and use command line cryptsetup it works fine:
password is accepted, dm_crypt is loaded, device shows up in /dev/mapper, and if
you try to mount it, it works.

Version-Release number of selected component (if applicable):
kernel-2.6.22.1-41.fc7
udev-113-9.fc7
device-mapper-1.02.17-7.fc7
cryptsetup-luks-1.0.3-4.fc7


How reproducible:
Always.


Steps to Reproduce:
1.insert an usb disk, encrypted with LUKS support
2.gnome shows a popup with password request
3.type the password
  
Actual results:
Nothing happens

Expected results:
Disk is mounted and an icon appears on desktop

Additional info:
It works with a Fresh install of Fedora with kernel 2.6.21-1.3194.fc7 and udev
udev-106-4.fc7. After an upgrade to 2.6.22 kernel and udev affected by a bug
(see https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=249282) it stops
working at all.
Using udevmonitor on a Fedora 7 installation stil with old kernel shows kernel
events about device mapper, that don't appears in a Fedora 7 installation with
all updates.
Again, in the updated Fedora no device appears in /dev/mapper, nor in /dev as
dm-X. Modules dm_crypt is not loaded at all.
If you use command line interface of cryptsetup it works flawlessy.
Comment 1 Till Maas 2007-08-13 04:45:28 EDT
(In reply to comment #0)

> Additional info:
> It works with a Fresh install of Fedora with kernel 2.6.21-1.3194.fc7 and udev
> udev-106-4.fc7. After an upgrade to 2.6.22 kernel and udev affected by a bug
> (see https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=249282) it stops
> working at all.
> Using udevmonitor on a Fedora 7 installation stil with old kernel shows kernel
> events about device mapper, that don't appears in a Fedora 7 installation with
> all updates.

It seems not to be a bug in cryptsetup, but in udev or kernel. Do I understand
correctly, that it works with the old Fedora 7 kernel and the new udev but not
with the new kernel and new udev? Then it sounds more like a kernel bug.

Comment 2 Mario Pascucci 2007-08-13 15:39:22 EDT
Here the combination I tried so far:
kernel               udev         
2.6.21-1.3194.fc7    106-4.1.fc7   WORKS
2.6.21-1.3228.fc7    106-4.1.fc7   WORKS
2.6.21-1.3194.fc7    113-9.fc7     WORKS

I also tried to downgrade another PC where disk is not mounted to Fedora 7
kernel and udev in the Fedora DVD, kernel-2.6.21-1.3194.fc7 and
udev-106-4.1.fc7, and doesn't work. This is strange.

I have two PC, one where mount works and one where don't works. The one where
automated mount works is not updated, so I look to the list of packages that
will be updated if I launch an update. The only package in list that seems
related is dbus-glib and, of course, kernel.

I'll try a step by step update to trigger the bug.
Comment 3 Till Maas 2007-08-13 16:54:20 EDT
Maybe the kernel maintainers know, what could be the buggy part here. Therefore
I reassign this bug.
Comment 4 Mario Pascucci 2007-08-13 17:12:33 EDT
...I'm confused now.

I've done a complete update to the PC where the problem was never spotted.
No problem at all: disk is mounted immediately after giving password.

Probably, when playing with udev for the problems of he last three weeks (see
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=249282) I've broken somathing.

So, please apologize. I'm really sorry.
Can I close the bug or must be closed by an admin?
Comment 5 Chuck Ebbert 2007-08-13 17:30:01 EDT
(In reply to comment #4)
> ...I'm confused now.
> 
> I've done a complete update to the PC where the problem was never spotted.
> No problem at all: disk is mounted immediately after giving password.
> 
> Probably, when playing with udev for the problems of he last three weeks (see
> https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=249282) I've broken
somathing.
> 
> So, please apologize. I'm really sorry.
> Can I close the bug or must be closed by an admin?
> 

You could have closed it, but too late now.  :)


Note You need to log in before you can comment on or make changes to this bug.