Bug 251898 - Dependency error for postfix-pflogsumm
Dependency error for postfix-pflogsumm
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-13 07:14 EDT by Jeroen van Meeuwen
Modified: 2014-01-21 17:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-13 10:16:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum -d9 install output (20.45 KB, application/octet-stream)
2007-08-13 07:14 EDT, Jeroen van Meeuwen
no flags Details

  None (edit)
Description Jeroen van Meeuwen 2007-08-13 07:14:17 EDT
Description of problem:
yum cannot satisfy dependency postfix = 2.4.3-2.fc7 for package
postfix-pflogsumm, while the dependency is met by postfix in updates

Version-Release number of selected component (if applicable):


How reproducible:
yum install postfix-pflogsumm

Steps to Reproduce:
1. yum clean all
2. yum install postfix-pflogsumm
3.
  
Actual results:
[kanarip@sara0202 revisor]$ sudo yum install postfix-pflogsumm.i386
Loading "protectbase" plugin
Setting up Install Process
Parsing package install arguments
fedora                    100% |=========================| 2.1 kB    00:00     
livna                     100% |=========================| 2.1 kB    00:00     
updates                   100% |=========================| 1.9 kB    00:00     
primary.sqlite.bz2        100% |=========================| 1.2 MB    00:00     
0 packages excluded due to repository protections
Resolving Dependencies
--> Running transaction check
---> Package postfix-pflogsumm.i386 2:2.4.3-2.fc7 set to be updated
--> Processing Dependency: perl(Date::Calc) for package: postfix-pflogsumm
--> Processing Dependency: postfix = 2.4.3-2.fc7 for package: postfix-pflogsumm
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package perl-Date-Calc.i386 0:5.4-1.2.2.1 set to be updated
---> Package postfix-pflogsumm.i386 2:2.4.3-2.fc7 set to be updated
--> Processing Dependency: perl(Bit::Vector) for package: perl-Date-Calc
--> Processing Dependency: perl(Carp::Clan) for package: perl-Date-Calc
--> Processing Dependency: perl-Bit-Vector >= 6.4 for package: perl-Date-Calc
--> Processing Dependency: postfix = 2.4.3-2.fc7 for package: postfix-pflogsumm
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package perl-Carp-Clan.noarch 0:5.9-1.fc7 set to be updated
---> Package perl-Date-Calc.i386 0:5.4-1.2.2.1 set to be updated
---> Package postfix-pflogsumm.i386 2:2.4.3-2.fc7 set to be updated
---> Package perl-Bit-Vector.i386 0:6.4-2.2.2.1 set to be updated
--> Processing Dependency: postfix = 2.4.3-2.fc7 for package: postfix-pflogsumm
--> Finished Dependency Resolution
Error: Missing Dependency: postfix = 2.4.3-2.fc7 is needed by package
postfix-pflogsumm
[kanarip@sara0202 revisor]$ sudo yum list | grep postfix
postfix.i386                             2:2.4.3-2.fc7          updates         
postfix-pflogsumm.i386                   2:2.4.3-2.fc7          updates

Expected results:

Installation of postfix-pflogsumm

Additional info:

Additional debug logging (-d9) attached
Comment 1 Jeroen van Meeuwen 2007-08-13 07:14:17 EDT
Created attachment 161166 [details]
yum -d9 install output
Comment 2 Jeroen van Meeuwen 2007-08-13 07:16:21 EDT
I see I skipped an item:

Version-Release number of selected component (if applicable):
[kanarip@sara0202 revisor]$ rpm -qv yum
yum-3.2.2-1.fc7
Comment 3 Seth Vidal 2007-08-13 10:16:00 EDT
in the changelog for postfix in rawhide

* Fri Jun 15 2007 Thomas Woerner <twoerner@redhat.com> 2:2.4.3-3
- added missing epoch in requirement of pflogsumm sub package



pflogsumm was looking for 0:2.4.3-2 of postfix when postfix is 2:2.4.3-2


Note You need to log in before you can comment on or make changes to this bug.