Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 251951 - luseradd never creates inetOrgPerson
luseradd never creates inetOrgPerson
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libuser (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Miloslav Trmač
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-13 12:30 EDT by Axel Thimm
Modified: 2013-10-31 14:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-31 14:59:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Axel Thimm 2007-08-13 12:30:32 EDT
Description of problem:
Using luseradd to add new users to an ldap database creates them w/o the
objectclass inetOrgPerson.

Perhaps this is a user error as I know that I had initially created users that
did get into the database as inetOrgPerson. But this was under Fedora, so
perhaps this is a version issue (FWIW I looked into the RHEL source and
inetOrgPerson is already mentioned there)?

Even if a user error, if you could point me to the proper usage and this is
bugzilla'd and googlized it will help future libuser users :)

Version-Release number of selected component (if applicable):
0.54.7-2.el5.1

How reproducible:
always

Steps to Reproduce:
1.luseradd <options> someuser
2.
3.
  
Actual results:
user is entered into ldap w/o objectclass inetOrgPerson

Expected results:
user should be inetOrgPerson

Additional info:
Ideally libuser would allow to even add further objectclasses like
inetLocalMailRecipient (expired mail routing draft) or other custom objectclasses.

Thanks!
Comment 1 Miloslav Trmač 2007-08-14 19:50:57 EDT
Thanks for your report.

The "sn" (surname) attribute is mandatory in inetOrgPerson.  Because luseradd
does not know and does not set the "sn" attribute, the created LDAP entry cannot
have the inetOrgPerson objectclass.


So, luseradd should allow specifying the gecos fields separately, with the side
effect that if one of them is present, "sn" must be present (because the
"account" objectclass does not contain the gecos fields), and inetOrgPerson is used.

Supporting other or custom object classes is outside of scope of libuser, which
is basically an alternative to (a subset of) NSS that allows modification of the
data.


If you are a RHEL customer and have an active support entitlement, please
contact official Red Hat Support at https://www.redhat.com/apps/support/ to
allow correct prioritization of this issue.
Comment 2 Axel Thimm 2007-12-30 05:14:37 EST
I have developer licenses which come with no support options other than
bugzilla'ing issues, and I can't get any customer to channel this through him.

We can close it or wait for someone willing to invest his support options into
this bugzilla. I'll leave it up to you. Thanks!
Comment 3 Miloslav Trmač 2009-12-11 05:55:22 EST
Fixed in rawhide and F-12 libuser-0.56.13.
Comment 4 RHEL Product and Program Management 2011-05-31 09:19:24 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2011-09-22 20:10:48 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 7 RHEL Product and Program Management 2012-06-11 21:03:17 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 8 Miloslav Trmač 2013-10-31 14:59:52 EDT
This Bugzilla has been reviewed by Red Hat and is not planned on being addressed in Red Hat Enterprise Linux 5, and therefore will be closed. If this bug is critical to production systems, please contact your Red Hat support representative and provide sufficient business justification. Issue is already fixed in RHEL-6/7.

Note You need to log in before you can comment on or make changes to this bug.