Bug 251956 - gstreamer-devel should require check-devel
gstreamer-devel should require check-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gstreamer (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-13 13:18 EDT by Matthias Saou
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 10:01:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthias Saou 2007-08-13 13:18:26 EDT
The "make check" from pigment uncovered this bug :

In file included from pgm/pgm.c:23:
/usr/include/gstreamer-0.10/gst/check/gstcheck.h:30:19: error: check.h: No such
file or directory
In file included from pgm/pgm.c:23:
/usr/include/gstreamer-0.10/gst/check/gstcheck.h:78: error: expected ‘)’ before
‘*’ token

The current gstreamer-devel package doesn't pull in check-devel, but it should
since some headers it provides explicitly #include check.h.
Comment 1 Matthias Clasen 2007-08-14 10:01:28 EDT
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.