Bug 252034 - forcedeth: missed 2 chunks from 0.60 backport
Summary: forcedeth: missed 2 chunks from 0.60 backport
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 5.0
Hardware: All Linux
high
low
Target Milestone: ---
: ---
Assignee: Andy Gospodarek
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-13 20:37 UTC by Andy Gospodarek
Modified: 2014-06-29 22:59 UTC (History)
2 users (show)

Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 19:59:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pci-push.patch (571 bytes, patch)
2007-08-13 20:37 UTC, Andy Gospodarek
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0959 normal SHIPPED_LIVE Updated kernel packages for Red Hat Enterprise Linux 5 Update 1 2007-11-08 00:47:37 UTC

Description Andy Gospodarek 2007-08-13 20:37:14 UTC
I missed these bits:

--- linux-2.6.18.x86_64/drivers/net/forcedeth.c.orig
+++ linux-2.6.18.x86_64/drivers/net/forcedeth.c
@@ -1722,7 +1722,6 @@ static int nv_start_xmit(struct sk_buff

        dev->trans_start = jiffies;
        writel(NVREG_TXRXCTL_KICK|np->txrxctl_bits, get_hwbase(dev) +
NvRegTxRxControl);
-       pci_push(get_hwbase(dev));
        return NETDEV_TX_OK;
 }

@@ -1851,7 +1850,6 @@ static int nv_start_xmit_optimized(struc

        dev->trans_start = jiffies;
        writel(NVREG_TXRXCTL_KICK|np->txrxctl_bits, get_hwbase(dev) +
NvRegTxRxControl);
-       pci_push(get_hwbase(dev));
        return NETDEV_TX_OK;
 }


from the following commits:

commit 445583b89d71b48cf8c64e26acc5a710248feed7
Author: Ayaz Abdulla <aabdulla@nvidia.com>
Date:   Sun Jan 21 18:10:47 2007 -0500

    forcedeth: tx data path optimization

    This patch optimizes the tx data paths and cleans up the code (removes
    vlan from descr1/2 since only valid for desc3, changes to make code
    easier to read, etc).

    Signed-Off-By: Ayaz Abdulla <aabdulla@nvidia.com>

    Signed-off-by: Jeff Garzik <jeff@garzik.org>

Comment 1 Andy Gospodarek 2007-08-13 20:37:14 UTC
Created attachment 161230 [details]
pci-push.patch

Comment 7 Don Zickus 2007-08-15 19:07:33 UTC
in 2.6.18-40.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5

Comment 9 Mike Gahagan 2007-08-30 15:27:50 UTC
Confirmed the missing bit has been added to the -43.el5 kernel

Comment 11 errata-xmlrpc 2007-11-07 19:59:14 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html



Note You need to log in before you can comment on or make changes to this bug.