Bug 252042 - Dogtail bombs when trying to 'from dogtail import tree'
Dogtail bombs when trying to 'from dogtail import tree'
Status: CLOSED DUPLICATE of bug 245733
Product: Fedora
Classification: Fedora
Component: dogtail (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Zack Cerza
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-13 16:48 EDT by Cole Robinson
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-16 11:52:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cole Robinson 2007-08-13 16:48:00 EDT
Description of problem:

Any invocation of 'from dogtail import tree' bombs with a pyspi error.

Version-Release number of selected component (if applicable):
[root@localhost dogtail]# rpm -q dogtail pyspi
dogtail-0.6.1-1.fc7
pyspi-0.6.1-3.fc7

How reproducible:
Always

Steps to Reproduce:
1. yum install dogtail
2. /usr/bin/sniff
3. View the error!
  
Actual results:

[root@localhost dogtail]# sniff
Creating logfile at /tmp/dogtail/logs/sniff_20070810-164511_debug ...
Detecting distribution: Fedora (or derived distribution)
GTK Accessibility Module initialized
Traceback (most recent call last):
  File "/usr/bin/sniff", line 10, in <module>
    from dogtail import tree
  File "/usr/lib/python2.5/site-packages/dogtail/tree.py", line 1255, in <module>
    children = root.children
  File "/usr/lib/python2.5/site-packages/dogtail/tree.py", line 468, in __getattr__
    a = self.__accessible.getChildAtIndex (i)
  File "pyspi.pyx", line 497, in atspi.Accessible.getChildAtIndex
  File "pyspi.pyx", line 146, in atspi.exception_handler
TypeError: exceptions must be strings, classes, or instances, not SpiException

Expected results:

Sniff runs and doesn't error/ can import tree without error.
Comment 1 Zack Cerza 2007-08-16 11:52:25 EDT

*** This bug has been marked as a duplicate of 245733 ***

Note You need to log in before you can comment on or make changes to this bug.