Bug 252168 - 80-drivers.rules reports error on boot
80-drivers.rules reports error on boot
Status: CLOSED DUPLICATE of bug 251815
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-14 08:56 EDT by Felix Bellaby
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 09:02:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felix Bellaby 2007-08-14 08:56:42 EDT
Description of problem:

Error messages reporting unknown format variables on boot
Probably breaks some pnp devices

Version-Release number of selected component (if applicable):

udev-114-1.fc8

How reproducible:

occurs on every boot

Additional info:

The following line in 80-drivers.rules generates the errors:

SUBSYSTEM=="pnp", DRIVER!="?*", ENV{MODALIAS}!="?*", \
  RUN{ignore_error}+="/bin/sh -c '/sbin/modprobe -a $(while read id; do echo
pnp:d$$id; done < /sys$devpath/id)'"

It should be replaced with the line:

SUBSYSTEM=="pnp", DRIVER!="?*", ENV{MODALIAS}!="?*", \
  RUN{ignore_error}+="/bin/sh -c '/sbin/modprobe -a $$(while read id; do echo
pnp:d$$id; done < /sys/$devpath/id)'"

Note use of escaped $ in $$(...)
Comment 1 Harald Hoyer 2007-08-14 09:02:26 EDT

*** This bug has been marked as a duplicate of 251815 ***

Note You need to log in before you can comment on or make changes to this bug.