Bug 252172 - Purge thumbnail cache on upgrade
Purge thumbnail cache on upgrade
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
http://bugzilla.gnome.org/show_bug.cg...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-14 09:51 EDT by Michael J. Chudobiak
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-15 14:20:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael J. Chudobiak 2007-08-14 09:51:31 EDT
Versions of libgnomeui prior to 2.19.0, gthumb prior to 2.9.1, and eog prior to
(?) generated image thumbnails without respecting the exif orientation tag.

The versions of libgnomeui/Nautilus, gthumb, and eog in F8 do respect the
orientation tag, but the old incorrect thumbnails may persist in the thumbnail
cache.

It would be nice if anaconda would purge the /home/*/*.thumbnails folders when
upgrading, to ensure that no incorrect thumbnails persist. The thumbnails are
automatically regenerated as required, of course.

The mixed-up orientations can be baffling to users, because the thumbnails and
full-sized images may differ without any obvious cause. The average user does
not know how to flush the thumbnail cache manually.

- Mike
Comment 1 Chris Lumens 2007-08-15 14:20:43 EDT
anaconda is not in the business of modifying a user's home directory on upgrade.
 This is the sort of thing that the users really need to be responsible for
instead.  First this opens the door to requests for us to do all sorts of things
- data migration between version of programs, etc. - that we are just not the
best people to work on.  Second, what about places with home directories on
remote systems or other similar setups?  This just wouldn't work there.

Note You need to log in before you can comment on or make changes to this bug.