Bug 252177 - exception for pirut when updating software
Summary: exception for pirut when updating software
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: 7
Hardware: i386 Linux
low
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-14 14:58 UTC by Yu Sheng
Modified: 2014-01-21 22:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-03 23:34:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash dump generated (23.01 KB, text/plain)
2007-08-14 14:58 UTC, Yu Sheng
no flags Details

Description Yu Sheng 2007-08-14 14:58:54 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
When automatically update the software.

Steps to Reproduce:
1. Just use startx to start the X environment, then it will reminds you have
some updates, after you input your superuser password, the exception will come out.
2.
3.
  
Actual results:
The program crash, and I've attached the dump file.


Expected results:


Additional info:

Comment 1 Yu Sheng 2007-08-14 14:58:54 UTC
Created attachment 161272 [details]
crash dump generated

Comment 2 Jeremy Katz 2007-08-14 17:51:37 UTC
What versions of yum and pirut do you have installed?

Comment 3 Yu Sheng 2007-08-14 18:09:00 UTC
(In reply to comment #2)
> What versions of yum and pirut do you have installed?


The version of yum is 3.2.1, the version of pirut is  1.3.9.
After several times of trying, pirut successfully updated the software this
morning. I don't know whether this problem will still appear in the future.

Comment 4 Jeremy Katz 2007-08-14 18:33:28 UTC
The exception was in the handling of a broken comps file.  yum should probably
not be raising an exception here but instead treating it like a repo without a
comps file.

Comment 5 Robert Hampton 2007-08-31 20:13:26 UTC
I have just a moment.  I saw this, or something very similar.  I'm a newbie &
don't understand your comment about comps (above).  After reading this, I took a
closer look at the error message.  It looked like pirut was failing because of
some problem with kdesdk.  I uninstalled kdesdk, then the updater ran without
failure.  I then reinstalled kdesdk.  It installed properly, and a subsequent
update indicated that everything was up to date and ok.  I hope this information
is helpful to someone.  Thanks much for your efforts to help out the community.

Comment 6 Seth Vidal 2007-09-03 23:34:11 UTC
This is all straight in 3.2.4 and above.



Note You need to log in before you can comment on or make changes to this bug.