This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 252187 - 32-bit rhel4u5 SMP guests crash on 32-bit AMD hypervisor
32-bit rhel4u5 SMP guests crash on 32-bit AMD hypervisor
Status: CLOSED DUPLICATE of bug 251013
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel-xen (Show other bugs)
4.5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Martin Jenner
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-14 12:25 EDT by Gurhan Ozen
Modified: 2013-11-03 20:33 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 13:54:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gurhan Ozen 2007-08-14 12:25:05 EDT
Description of problem:

 Got this with the very latest kernel clalance compiled with patches, but got
reports that it does happen with the latest rhel5.1 tree as well. The kernel on
the box can be obtained from /mnt/redhat/brewroot/scratch/clalance/task_916391 . 

# virt-install -n rhel4u5_pv --paravirt -s 10 -r 512 -l
http://porkchop.devel.redhat.com/released/RHEL-4/U5/AS/i386/tree -f
/var/lib/xen/images/rhel4u5_pv.img --nographics --vcpus=2


Starting install...
Retrieving RedHat...      100% |=========================|  941 B    00:00     
Retrieving vmlinuz...     100% |=========================| 1.0 MB    00:00     
Retrieving initrd.img...  100% |=========================| 854 kB    00:00     
Creating domain...                                                 0 B 00:00 
Linux version 2.6.9-55.ELxenU (brewbuilder@ls20-bc2-14.build.redhat.com) (gcc
version 3.4.6 20060404 (Red Hat 3.4.6-3)) #1 SMP Fri Apr 20 17:30:23 EDT 2007
BIOS-provided physical RAM map:
 Xen: 0000000000000000 - 0000000020000000 (usable)
0MB HIGHMEM available.
520MB LOWMEM available.
NX (Execute Disable) protection: active
IRQ lockup detection disabled
Built 1 zonelists
Kernel command line:  
method=http://porkchop.devel.redhat.com/released/RHEL-4/U5/AS/i386/tree
Initializing CPU#0
CPU 0 irqstacks, hard=c0338000 soft=c0318000
PID hash table entries: 4096 (order: 12, 65536 bytes)
Xen reported: 2593.494 MHz processor.
Console: colour dummy device 80x25
Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
vmalloc area: e1000000-f4ffe000, maxmem 2d800000
Memory: 505532k/532480k available (1450k kernel code, 18644k reserved, 539k
data, 124k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Security Scaffold v1.0.0 initialized
SELinux:  Initializing.
SELinux:  Starting in permissive mode
There is already a security framework initialized, register_security failed.
selinux_register_security:  Registering secondary module capability
Capability LSM initialized as secondary
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 1024K (64 bytes/line)
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
CPU 1 irqstacks, hard=c0339000 soft=c0319000
------------[ cut here ]------------
kernel BUG at drivers/xen/core/smpboot.c:240!
invalid operand: 0000 [#1]
SMP 
Modules linked in:
CPU:    0
EIP:    0061:[<c01f9ad5>]    Not tainted VLI
EFLAGS: 00010282   (2.6.9-55.ELxenU) 
EIP is at cpu_initialize_context+0x182/0x195
eax: ffffffea   ebx: 00000000   ecx: 00000001   edx: c163d4c8
esi: 00000001   edi: c163d6c8   ebp: c16710e0   esp: c163d4c4
ds: 007b   es: 007b   ss: 0068
Process swapper (pid: 1, threadinfo=c163d000 task=c1671670)
Stack: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 
       00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 
       00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 
Call Trace:
 [<c01f9949>] cpu_bringup_and_idle+0x0/0xa
 [<c01074d4>] divide_error+0x0/0x8
 [<c0107624>] debug+0x0/0x24
 [<c0107674>] int3+0x0/0x24
 [<c0107698>] overflow+0x0/0xc
 [<c01076a4>] bounds+0x0/0xc
 [<c01076b0>] invalid_op+0x0/0xc
 [<c0107604>] device_not_available+0x0/0x20
 [<c01076bc>] coprocessor_segment_overrun+0x0/0xc
 [<c01076c8>] invalid_TSS+0x0/0xc
 [<c01076d4>] segment_not_present+0x0/0xc
 [<c01076e0>] stack_segment+0x0/0xc
 [<c01076ec>] general_protection+0x0/0xc
 [<c0107704>] page_fault+0x0/0xc
 [<c0107710>] fixup_4gb_segment+0x0/0xc
 [<c01075ec>] coprocessor_error+0x0/0xc
 [<c01076f8>] alignment_check+0x0/0xc
 [<c01075f8>] simd_coprocessor_error+0x0/0xc
 [<c0107348>] system_call+0x0/0x30
 [<c010750c>] hypervisor_callback+0x0/0x34
 [<c01075ac>] failsafe_callback+0x0/0x40
 [<c0301476>] smp_prepare_cpus+0x185/0x1b4
 [<c010225e>] init+0x32/0x17a
 [<c010222c>] init+0x0/0x17a
 [<c0105341>] kernel_thread_helper+0x5/0xb
Code: c0 75 0d a1 a0 80 35 c0 8b 04 90 25 ff ff ff 7f c1 e0 0c 31 db 8d 54 24 04
89 84 24 ac 0a 00 00 89 f1 e8 2f 78 f0 ff 85 c0 74 08 <0f> 0b f0 00 eb f8 27 c0
81 c4 f4 0a 00 00 5b 5e 5f 5d c3 e8 dc 
 <0>Fatal exception: panic in 5 seconds


Version-Release number of selected component (if applicable):

[root@amd-tyan-09 vatest]# uname -a
Linux amd-tyan-09.lab.boston.redhat.com 2.6.18-39.el5.newnpt2xen #1 SMP Fri Aug
10 18:04:18 EDT 2007 i686 athlon i386 GNU/Linux
[root@amd-tyan-09 vatest]# rpm -q xen 
xen-3.0.3-33.el5
[root@amd-tyan-09 vatest]#

Note that I can't reproduce this on an Intel box.

How reproducible:
Very.

Steps to Reproduce:
1. 
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Lalancette 2007-08-14 13:48:45 EDT
Gurhan,
     Yeah, unfortunately, this is a bug with the 4.5 kernel, when you do the
install with --vcpus=2 (or more).  It should go away if you just use 1 vCPU. 
Note that this should also be fixed by using the 4.6 install tree....would you
mind testing that out and reporting back?  This is pretty much a dup of 251013,
so once I hear back from you, I'll close this out.

Thanks,
Chris Lalancette
Comment 2 Chris Lalancette 2007-08-14 13:54:53 EDT

*** This bug has been marked as a duplicate of 251013 ***
Comment 3 Gurhan Ozen 2007-08-14 14:09:58 EDT
(In reply to comment #1)
> Gurhan,
>      Yeah, unfortunately, this is a bug with the 4.5 kernel, when you do the
> install with --vcpus=2 (or more).  It should go away if you just use 1 vCPU. 
> Note that this should also be fixed by using the 4.6 install tree....would you
> mind testing that out and reporting back?  This is pretty much a dup of 251013,
> so once I hear back from you, I'll close this out.
> 
> Thanks,
> Chris Lalancette

I am installating rhel4u6 PV SMP guests on both AMD and Intel boxes and the
installation seems to be going just fine. They are installing packages at the
moment, so it's safe to assume that this issue doesn't exist on rhel4u6 guests.

Note You need to log in before you can comment on or make changes to this bug.