Bug 252320 - ipv6 support for suck (patch included)
Summary: ipv6 support for suck (patch included)
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: suck   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jochen Schmitt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-15 12:08 UTC by Tomasz Kepczynski
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 4.3.2-17.fc7.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-10 16:54:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ipv6 support for suck (8.66 KB, patch)
2007-08-15 12:08 UTC, Tomasz Kepczynski
no flags Details | Diff

Description Tomasz Kepczynski 2007-08-15 12:08:40 UTC
As in title.
Patched suck builds on i386 and x86-64.
I've tried suck against my own inn and newszilla6.xs4all.nl and
news.gazeta.pl and it seems to work.
More testing would be nice.
It can be easily extended to go through a list of all
addresses and not to try only the first one (I may do this
a bit later).
Patch is attached.

Comment 1 Tomasz Kepczynski 2007-08-15 12:08:41 UTC
Created attachment 161348 [details]
ipv6 support for suck

Comment 2 Jochen Schmitt 2007-08-15 16:09:01 UTC
At first 'Thank you for your work'.

I have create suck-4.3.2-16 on rawhide. It will be nice, if anyone can take a test.

On my system it seems to work, but I have not a IP6 connection to a foreign
newsserver.



Comment 3 Jochen Schmitt 2007-08-15 17:25:36 UTC
Because I have found some defects which affect only 64 bit systems, I have
create suck-4.3.2-17 for rawhide.

Comment 4 Fedora Update System 2007-09-04 22:06:45 UTC
suck-4.3.2-17.fc7.1 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2007-09-10 16:54:33 UTC
suck-4.3.2-17.fc7.1 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.