Bug 252330 - 0perl-Net-DNS .spec uses an obsolete option to suppress online tests
0perl-Net-DNS .spec uses an obsolete option to suppress online tests
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: perl-Net-DNS (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-15 09:36 EDT by R P Herrold
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-15 10:05:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2007-08-15 09:36:33 EDT
Description of problem:

.spec file uses an obsolete option for suppressing external tests

Version-Release number of selected component (if applicable):

perl-Net-DNS-0.60.1

How reproducible:

Rebuild it
Steps to Reproduce:
1.
2.
3.
  
Actual results:

+ cd Net-DNS-0.60
+ /usr/bin/perl Makefile.PL INSTALLDIRS=vendor --no-online-tests


The libraries needed to support IPv6 transport have not been found.
You will need recent versions of the IO::Socket::INET6 and Socket6
libraries (from CPAN).

Unknown option: no-online-tests
Testing if you have a C compiler and the needed header files....
You have a working compiler.

You appear to be directly connected to the Internet.  I have some tests
that try to query live nameservers.

Do you want to enable these tests? [y] n
Checking if your kit is complete...


Expected results:

NOT to have to answered n interactively

silent suppression of the test question, and not doig tests

Additional info:
Comment 1 Robin Norwood 2007-08-15 10:05:36 EDT
Thanks for the bug report, but I'm confused by a few things.

First, perl-Net-DNS-0.60 has never shipped with RHEL5 - we shipped with
perl-Net-DNS-0.59-1, and released perl-Net-DNS-0.59-3 as a security errata, with
some backported fixes from 0.60.  

See:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/SRPMS/perl-Net-DNS-0.59-1.fc6.src.rpm
and:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/SRPMS/perl-Net-DNS-0.59-3.el5.src.rpm


Also, the --no-online-tests option appears to be a valid option for all recent
versions of Net::DNS.  The option is documented here, for instance:

http://search.cpan.org/src/OLAF/Net-DNS-0.60/README

And is also still present in the latest version (0.61), available in Fedora 7
and Fedora rawhide.

So I'm not sure how you are getting this error.  I tested rebuilds of both RHEL5
versions and the latest version here, and I'm not getting such an error.

Closing this bug for now.  If you can help me reproduce this, feel free to
reopen the bug and I'll take another look.
Comment 2 R P Herrold 2007-08-15 10:27:22 EDT
understood that it is docoed one way, but I report the observed behaviour  ;)

hmmm ... looks like I pulled it from my accretive RawHide/Fedora mirror, as it
turns out ... 

/mnt/nfs/var/ftp/pub/mirror/redhat/rawhide/SRPMS/perl-Net-DNS-0.60-1.fc8.src.rpm

I'll check 0.61

Note You need to log in before you can comment on or make changes to this bug.