Bug 25250 - header function broken in php-4.0.4pl1-3
Summary: header function broken in php-4.0.4pl1-3
Status: CLOSED DUPLICATE of bug 24933
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
high
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-30 01:49 UTC by phostetl
Modified: 2007-03-27 03:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-30 06:07:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description phostetl 2001-01-30 01:49:47 UTC
I have a form that sets var to some filename and calls the following php
code.  I use it to force headers so that a file download occurs without
revealing the path.  This worked until  php-4.0.4pl1-3.  I have the php.ini
set to enable multiple header transmission.

<?
header ("Location: /downloads/$var");
?>
 
The problem is that a bunch of blank lines now preceed the header.

I also force headers for uploads. My upload function still works.

Comment 1 phostetl 2001-01-30 03:43:28 UTC
It turn out that $var from my form somehow picked up additional whitespace.  I
corrected the problem with:

<?
$qnx="/downloads/".trim($var);
header ("Location: $qnx");
?> 

But this shouldn't have happened.  There isn't anything regarding this in the
release notes.

Comment 2 Nalin Dahyabhai 2001-01-30 06:08:10 UTC
Bug #24933 strikes again.  The form-parsing code is pretty involved; I'm still
tracing through it to try figuring out where things go awry, but I can guess
that it works in Netscape Navigator....

*** This bug has been marked as a duplicate of 24933 ***


Note You need to log in before you can comment on or make changes to this bug.