Bug 25253 - Internal compiler error from gcc-2.96
Summary: Internal compiler error from gcc-2.96
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-30 02:56 UTC by Need Real Name
Modified: 2007-04-18 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 20:31:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
preprocessed eispackd.i (289.15 KB, application/octet-stream)
2001-01-30 23:14 UTC, Need Real Name
no flags Details

Description Need Real Name 2001-01-30 02:56:56 UTC
I  was trying to compile eispackd.c which is converted from eispackd.f
using f2c, and I got an Internal compiler error message:

gcc -Wall  -O3 -ggdb3  -funroll-all-loops -fomit-frame-pointer    
-DNDEBUG  -DCOMPLEX_VECS   -c -o eispackd.o eispackd.c. 

The eispackd.f is available at http://www.netlib.org/eispack.

The code will compile with g++ 2.91.66 compiler. I have already done the
most recent
update for glibc (RHBA-2000:132-05). Do you have any suggestions for the
problem? 

Thank you very much.

Wayne Lau

Comment 1 Jakub Jelinek 2001-01-30 21:28:02 UTC
Can you attach here preprocessed eispackd.i? You can get it e.g. by
running
gcc -Wall  -O3 -ggdb3  -funroll-all-loops -fomit-frame-pointer
-DNDEBUG  -DCOMPLEX_VECS   -E -o eispackd.i eispackd.c
(with preprocessed source I'm sure we're seeing the same thing).
I think it is most probably some dwarf2out issue triggered by
-ggdb3. If you attach the preprocessed source here, I'll try to debug
it.

Comment 2 Need Real Name 2001-01-30 23:14:37 UTC
Created attachment 8522 [details]
preprocessed eispackd.i

Comment 3 Jakub Jelinek 2001-01-31 10:10:20 UTC
Ok, it is a dwarf2out bug, reproduceable with just -O3 -gdwarf-2.

Comment 4 Jakub Jelinek 2001-09-06 16:55:50 UTC
Oops, forgot to close this. It should be fixed since 2.96-81.

Comment 5 Bill Nottingham 2006-08-04 20:31:29 UTC
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.


Note You need to log in before you can comment on or make changes to this bug.