Bug 25258 - Fisher anaconda doesn't like partitions not on cylinder boundries
Fisher anaconda doesn't like partitions not on cylinder boundries
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-29 22:33 EST by Matt Domsch
Modified: 2014-03-16 22:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-13 01:08:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2001-01-29 22:33:28 EST
Below is the MBR (hexdump) of a disk created with the IA-64 
EFI "fdisk.efi" utility.  It creates a 100MB type 0xef partition at the 
front of the disk, erasing all other partition entries.

0000000 0045 0046 0049 0020 0046 0044 0049 0053
0000010 004b 0000 0000 0000 0000 0000 0000 0000
0000020 0000 0000 0000 0000 0000 0000 0000 0000
*
00001b0 0000 0000 0000 0000 2233 0011 0000 0000
00001c0 0000 00ef 0000 003f 0000 2000 0003 0000
00001d0 0000 0000 0000 0000 0000 0000 0000 0000
*
00001f0 0000 0000 0000 0000 0000 0000 0000 aa55
0000200

Fisher anaconda complains that the partition doesn't end on a cylinder, 
and won't continue.  With beta2, it worked just fine.  Is this change 
intentional?
Comment 1 Michael Fulbright 2001-01-30 16:41:45 EST
Did you partition the drive with beta2?

Is this a SCSI or IDE drive?
Comment 2 Matt Domsch 2001-01-31 00:56:18 EST
This is a SCSI drive on an IA-64 "Lion" (really Dell Bordeaux) system.  Sector 
0 was filled with zeros, then the EFI app fdisk.efi was run which created the 
partition table above.  This same scenario worked with beta2, and now fails 
with beta3.
Comment 3 Michael Fulbright 2001-02-01 13:29:50 EST
Checking to see if we have the hw to reproduce.

If you boot into rescue mode, and run 'fdisk -l <device>' on the drive in
question, what is the output?
Comment 4 Matt Domsch 2001-02-04 12:06:57 EST
sh-2.04# fdisk -l ./sdb
kernel version 132096

Disk ./sdb: 255 heads, 63 sectors, 1106 cylinders
Units = cylinders of 16065 * 512 bytes

Device Boot    Start       End    Blocks   Id  System
./sdb1             1        13    102400   ef  EFI (FAT-12/16/32)
Partition 1 does not end on cylinder boundary:
     phys=(0, 0, 0) should be (0, 254, 63)
Comment 5 Michael Fulbright 2001-02-06 15:35:11 EST
Apparently efi thinks the partition of the drive is different than the Linux
kernel, which finds it to be 255 heads, 63 sectors, 1106 cylinders.

Can you get fdisk.efi to tell you its assumed geometry of the drive?
Comment 6 Gerald Teschl 2001-02-08 13:36:47 EST
Same here on an asus laptop with a 10GB IBM drive.
[root@soliton gerald]# fdisk -l /dev/hda
 
Disk /dev/hda: 16 heads, 63 sectors, 15880 cylinders
Units = cylinders of 1008 * 512 bytes
 
   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1      5595   2819848+   b  Win95 FAT32
Partition 1 does not end on cylinder boundary:
     phys=(372, 239, 63) should be (372, 15, 63)
/dev/hda2          5596      5805    105840   a0  IBM Thinkpad hibernation
Partition 2 does not end on cylinder boundary:
     phys=(386, 239, 63) should be (386, 15, 63)
/dev/hda3          5806     15495   4883760   83  Linux
Partition 3 does not end on cylinder boundary:
     phys=(1023, 239, 63) should be (1023, 15, 63)
/dev/hda4         15496     15870    189000   82  Linux swap
Partition 4 does not end on cylinder boundary:
     phys=(1023, 239, 63) should be (1023, 15, 63)
Comment 7 Matt Domsch 2001-02-21 14:33:33 EST
> From: Stephane Eranian [mailto:eranian@frankl.hpl.hp.com]
> I was able to narrow down the problem I was having with 
> fisher refusing to install because of something bad
> with the partition table. It turns out that the program
> somehow refuses disks in which partitions are
> not properly aligned on cylinder boundaries. So I ended
> up wiping out my disk to be able to get through. 
> 
> I think fisher if overeacting here. It should warn you
> and give you a chance to repartition via fdisk or
> disk druid.

Agreed, and this is in bugzilla already, 
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=25258.  The Intel-provided 
fdisk.efi creates an MBR partition table, but since EFI doesn't care about CHS 
geometry, it leaves the starting *and ending* CHS values as 0 when creating the 
100MB EFI System Partition.  In Fisher, anaconda doesn't like this.  Switching 
to VT2 and fixing it via fdisk, then switching back to VT1, lets you get around 
the problem.  I've changed my install script to not use fdisk.efi anymore, for 
exactly this reason.

-Matt
Comment 8 Matt Domsch 2001-03-20 15:54:38 EST
This still occurs with the qa0319 cut for IA-32 as well.
Comment 9 Bill Nottingham 2001-05-04 13:04:05 EDT
I'm assuming this is a problem with Wolverine as well?
Comment 10 Matt Domsch 2001-05-04 13:44:07 EDT
Last time I checked, yes.  I stopped using Intel's fdisk.efi app because of 
this, and just create /boot/efi in the installer.  If our factory install 
process creates /boot/efi for me somehow, it may not be aligned, and anaconda 
will complain again.

(As long as we're mucking with partition tables, parted-1.4.11-2 lays down a 
protective MBR (when creating a GPT label) that fdisk doesn't like.
Disk /dev/sdb: 255 heads, 63 sectors, 5461 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/sdb1             1      5462  43868160   ee  EFI GPT
Partition 1 does not end on cylinder boundary:
     phys=(1023, 255, 62) should be (1023, 254, 63)

Should I change parted to have it be 1023,254,63 instead?  Easy enough if so.)
Comment 11 Matt Domsch 2001-06-13 01:08:24 EDT
Florence added stricter tests to ensure MBR partitions end on cylinder 
boundries, which is where this came from.  Florence IA-64 uses GPT on blank 
disks, and the Intel-provided fdisk.efi is no longer ever needed.
I'll mark this as Wontfix, and it can be closed.

Note You need to log in before you can comment on or make changes to this bug.