Bug 252712 - stardict-3.0.0-1.fc8 could not execute
Summary: stardict-3.0.0-1.fc8 could not execute
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: stardict (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
low
low
Target Milestone: ---
Assignee: Hu Zheng
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 253359 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-16 06:23 UTC by ZipanChen
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version: 1.28-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-24 05:36:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ZipanChen 2007-08-16 06:23:13 UTC
How reproducible:
When I yum update stardict to stardict-3.0.0-1.fc8, it could not execute.


Steps to Reproduce:
1. Install Fedora 8 Test 1
2. Yum update
3. Execute Stardict
  
Additional info:
stardict
Gtk-Message: Failed to load module "gnomebreakpad": libgnomebreakpad.so: cannot
open shared object file: No such file or directory
Wiki data parse plug-in loaded.
PowerWord data parse plug-in loaded.
User dict plug-in loaded.
HTML data parse plug-in loaded.
Spell plug-in loaded.
XDXF data parse plug-in loaded.
Man plug-in loaded.
*** glibc detected *** stardict: malloc(): memory corruption: 0x0000000000947050 ***
======= Backtrace: =========
/lib64/libc.so.6[0x31e3870f3c]
/lib64/libc.so.6(__libc_malloc+0x7a)[0x31e387284a]
/usr/lib64/libespeak.so.1[0x2aaab1964009]
/usr/lib64/libespeak.so.1[0x2aaab197011e]
/usr/lib64/libespeak.so.1(espeak_Initialize+0x52)[0x2aaab1963312]
/usr/lib64/stardict/plugins/stardict_espeak.so(stardict_tts_plugin_init+0x18)[0x2aaab175c768]
stardict[0x48130e]
stardict[0x4837b7]
stardict[0x4839f6]
stardict[0x48163d]
stardict[0x481834]
stardict[0x4180e2]
stardict[0x419938]
stardict[0x41a2be]
/lib64/libc.so.6(__libc_start_main+0x188)[0x31e381dd58]
stardict[0x40f349]
======= Memory map: ========
00400000-004a5000 r-xp 00000000 08:01 624074                            
/usr/bin/stardict
006a5000-006c7000 rw-p 000a5000 08:01 624074                            
/usr/bin/stardict
006c7000-00951000 rw-p 006c7000 00:00 0                                  [heap]
31e3400000-31e341a000 r-xp 00000000 08:01 216430                        
/lib64/ld-2.6.90.so
31e361a000-31e361b000 r--p 0001a000 08:01 216430                        
/lib64/ld-2.6.90.so
31e361b000-31e361c000 rw-p 0001b000 08:01 216430                        
/lib64/ld-2.6.90.so
31e3800000-31e3948000 r-xp 00000000 08:01 216432                        
/lib64/libc-2.6.90.so
31e3948000-31e3b48000 ---p 00148000 08:01 216432                        
/lib64/libc-2.6.90.so
31e3b48000-31e3b4b000 r--p 00148000 08:01 216432                        
/lib64/libc-2.6.90.so
31e3b4b000-31e3b4d000 rw-p 0014b000 08:01 216432                        
/lib64/libc-2.6.90.so
31e3b4d000-31e3b52000 rw-p 31e3b4d000 00:00 0 
31e3c00000-31e3c82000 r-xp 00000000 08:01 216440                        
/lib64/libm-2.6.90.so
31e3c82000-31e3e81000 ---p 00082000 08:01 216440                        
/lib64/libm-2.6.90.so
31e3e81000-31e3e83000 rw-p 00081000 08:01 216440                        
/lib64/libm-2.6.90.so
31e4000000-31e4002000 r-xp 00000000 08:01 216442                        
/lib64/libdl-2.6.90.so
31e4002000-31e4202000 ---p 00002000 08:01 216442                        
/lib64/libdl-2.6.90.so
31e4202000-31e4204000 rw-p 00002000 08:01 216442                        
/lib64/libdl-2.6.90.so
31e4400000-31e44c6000 r-xp 00000000 08:01 216434                        
/lib64/libglib-2.0.so.0.1400.0
31e44c6000-31e46c5000 ---p 000c6000 08:01 216434                        
/lib64/libglib-2.0.so.0.1400.0
31e46c5000-31e46c7000 rw-p 000c5000 08:01 216434                        
/lib64/libglib-2.0.so.0.1400.0
31e4800000-31e4814000 r-xp 00000000 08:01 216447                        
/lib64/libz.so.1.2.3
31e4814000-31e4a13000 ---p 00014000 08:01 216447                        
/lib64/libz.so.1.2.3
31e4a13000-31e4a14000 rw-p 00013000 08:01 216447                        
/lib64/libz.so.1.2.3
31e4c00000-31e4c3e000 r-xp 00000000 08:01 216446                        
/lib64/libgobject-2.0.so.0.1400.0
31e4c3e000-31e4e3e000 ---p 0003e000 08:01 216446                        
/lib64/libgobject-2.0.so.0.1400.0
31e4e3e000-31e4e40000 rw-p 0003e000 08:01 216446                        
/lib64/libgobject-2.0.so.0.1400.0
31e5000000-31e5104000 r-xp 00000000 08:01 89590                         
/usr/lib64/libX11.so.6.2.0
31e5104000-31e5304000 ---p 00104000 08:01 89590                         
/usr/lib64/libX11.so.6.2.0
31e5304000-31e530b000 rw-p 00104000 08:01 89590                         
/usr/lib64/libX11.so.6.2.0
31e5400000-31e5405000 r-xp 00000000 08:01 89589                         
/usr/lib64/libXdmcp.so.6.0.0
31e5405000-31e5604000 ---p 00005000 08:01 89589                         
/usr/lib64/libXdmcp.so.6.0.0
31e5604000-31e5605000 rw-p 00004000 08:01 89589                         
/usr/lib64/libXdmcp.so.6.0.0
31e5800000-31e5802000 r-xp 00000000 08:01 89587                         
/usr/lib64/libXau.so.6.0.0
31e5802000-31e5a01000 ---p 00002000 08:01 89587                         
/usr/lib64/libXau.so.6.0.0
31e5a01000-31e5a02000 rw-p 00001000 08:01 89587                         
/usr/lib64/libXau.so.6.0.0
31e5c00000-31e5c16000 r-xp 00000000 08:01 216451                        
/lib64/libpthread-2.6.90.so
31e5c16000-31e5e15000 ---p 00016000 08:01 216451                        
/lib64/libpthread-2.6.90.so
31e5e15000-31e5e17000 rw-p 00015000 08:01 216451                        
/lib64/libpthread-2.6.90.so
31e5e1Aborted

Comment 1 Hu Zheng 2007-08-17 02:19:41 UTC
This bug only happen on x86_64 english locale. It is the bug of espeak in fact.
I hope the espeak maintainer can fix this bug.

Current solution: rm /usr/lib64/stardict/plugins/stardict_espeak.so


Comment 2 Hu Zheng 2007-08-20 02:02:53 UTC
*** Bug 253359 has been marked as a duplicate of this bug. ***

Comment 3 Hu Zheng 2007-08-20 03:17:53 UTC
I find the problem:
In espeak source code:
synthdata.cpp:635
p = Alloc(strlen(string+1));
Should be:
p = Alloc(strlen(string)+1);

Francois Aucamp, can you fix this bug? I have already reported this to upstream
too, see: 
http://sourceforge.net/tracker/index.php?func=detail&aid=1761788&group_id=159649&atid=812675

Comment 4 Francois Aucamp 2007-08-20 07:41:46 UTC
Hi, yes, I'll update espeak for F7 and F8 today, and apply the required patch.
Thanks for your work in finding the problem! :-)

Comment 5 Francois Aucamp 2007-08-20 10:24:18 UTC
Ok, espeak 1.28 (with Hu Zheng's solution applied) has now been submitted to
rawhide (F8) and pushed to F7 updates-testing
(https://admin.fedoraproject.org/updates/pending/F7/espeak-1.28-1.fc7)

Please test it as soon as it is admitted to updates-testing, and let me know if
this solves the issue. Thanks everyone!

Comment 6 Fedora Update System 2007-08-20 16:01:53 UTC
espeak-1.28-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Ronald Warsow 2007-08-20 16:49:56 UTC
okay sucked in. looks good

thx.

Comment 8 Hu Zheng 2007-08-21 03:33:08 UTC
I have tested it. The crash bug is solved! You can push it to stable now. Thank you!

Comment 9 Fedora Update System 2007-08-24 05:36:47 UTC
espeak-1.28-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.