Bug 252936 - build-id patch breaks binutils on alpha
build-id patch breaks binutils on alpha
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: binutils (Show other bugs)
rawhide
alpha Linux
low Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-16 02:58 EDT by Oliver Falk
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-16 11:16:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Falk 2007-08-16 02:58:03 EDT
Jakub. We talked about this already, but now I can confirm. The build-id patch
breaks binutils on alpha. I have built binutils without the build-id patches and
it works just fine...
I'm very willing to help to fix this - just let me know how.
Comment 1 Jakub Jelinek 2007-08-16 03:03:49 EDT
2007-07-10  Alan Modra  <amodra@bigpond.net.au>

        * elf32-arm.c (elf32_arm_size_info): Init checksum_contents field.
        * elf64-alpha.c (alpha_elf_size_info): Likewise.
        * elf64-hppa.c (hppa64_elf_size_info): Likewise.
        * elf64-mips.c (mips_elf64_size_info): Likewise.
        * elf64-s390.c (s390_elf64_size_info): Likewise.
        * elf64-sparc.c (elf64_sparc_size_info): Likewise.

Unfortunately, the patch is GPLv3.  Guess I will upgrade binutils to 2.17.50.0.18
anyway and let frysk take care of the licensing issues it creates.
The libopcodes.a library is linked statically into frysk, so until frysk is
rebuilt this doesn't cause any problems.
Comment 2 Oliver Falk 2007-08-16 03:19:06 EDT
Thx Jakub. I'll see your commit to binutils in my mails and will try the latest
cvs co then :-)
Comment 3 Jakub Jelinek 2007-08-16 11:16:34 EDT
Should be fixed in binutils-2.17.50.0.18-1.
Comment 4 Oliver Falk 2007-08-16 11:18:01 EDT
Already compiled, but due to some other processes consuming my test-alpha-power,
I havn't yet tested it. I hope I can manage that in the next 30 minutes...
Comment 5 Oliver Falk 2007-08-16 12:06:03 EDT
Yes, this one works! Thx a lot Jakub; My personal hero! :-)

Note You need to log in before you can comment on or make changes to this bug.