Bug 252942 - 5 channels are not supported in alsa
5 channels are not supported in alsa
Status: CLOSED DUPLICATE of bug 252943
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: alsa-lib (Show other bugs)
5.1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-16 04:03 EDT by Jane Lv
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-16 06:42:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A five channels WAVE audio file (292.70 KB, audio/wav)
2007-08-16 04:03 EDT, Jane Lv
no flags Details

  None (edit)
Description Jane Lv 2007-08-16 04:03:18 EDT
Description of problem:
I tested RHEL5.1-snapshot-1 kernel-2.6.18-37.el5-x86_64 on Intel Weybridge SDV 
platform.  The codec is SigmaTel STAC9274D.

When playing a 5 channels audio file, there is an error message "alsa-init: 5 
channels are not supported".  I checked 
file /proc/asound/card0/pcm0p/sub0/hw_params and found only 2 channels are 
open.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:

1. Play the audio file,
[root@localhost ~]# mplayer fivechannels.wav
MPlayer 1.0rc1-4.1.2 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Core(TM)2 Duo CPU      6600  @ 2.40GHz (Family: 6, Model: 15, 
Stepping: 9)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Playing fivechannels.wav.
Audio file file format detected.
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 44100 Hz, 5 ch, s16le, 3528.0 kbit/100.00% (ratio: 441000->441000)
Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
==========================================================================
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or 
directory
alsa-init: 5 channels are not supported
AO: [alsa] 48000Hz 5ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:   0.4 (00.3) of 0.7 (00.6)  1.3%

Exiting... (End of file)

2. At the same time, check hw_params,
[root@localhost ~]# cat /proc/asound/card0/pcm0p/sub0/hw_params
access: MMAP_INTERLEAVED
format: S16_LE
subformat: STD
channels: 2
rate: 48000 (48000/1)
period_size: 1024
buffer_size: 16384
tick_time: 1000

[root@localhost ~]# file fivechannels.wav
fivechannels.wav: RIFF (little-endian) data, WAVE audio, 5 channels 44100 Hz

  
Actual results:
Only 2 channels are open.

Expected results:
5 channels are open.

Additional info:
The attached file is a 5 channels WAVE file with only data in center channel.  
So the expectation of playing this file is to get sound only in center 
channel.  From the current test result, there is no sound in center channel.
Comment 1 Jane Lv 2007-08-16 04:03:19 EDT
Created attachment 161633 [details]
A five channels WAVE audio file
Comment 2 Martin Stransky 2007-08-16 06:42:15 EDT

*** This bug has been marked as a duplicate of 252943 ***

Note You need to log in before you can comment on or make changes to this bug.